Help removing HID kit - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-18-2013, 06:40 PM Thread Starter
Junior Member
 
Hansolo's Avatar
 
Join Date: Jun 2013
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Help removing HID kit

My low beam headlight stopped working which apparently was a HID bulb, got the bike a few months ago and hadn't noticed since I ride only during daytime. I did notice it was a hint of blue but figured it was one of those ricer bulbs.

My question being are these kits fairly easy to bring back to stock? I do not want the HID. I noticed that the standard H7? adapter is gone in place of the HID bulb. What would be needed to bring back to stock. Thanks in advance.
Hansolo is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-18-2013, 09:08 PM Thread Starter
Junior Member
 
Hansolo's Avatar
 
Join Date: Jun 2013
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Update - I have since ordered the OEM socket adapter and rubber cover since the original one was hacked a bit.

I guess I need to order a connector, similar what the OEM used. The connector looks kind of like a H4 adapter even though the bulb is a H7, little confused.
Hansolo is offline  
post #3 of 5 (permalink) Old 08-18-2013, 09:32 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
Try here for connectors

http://www.easternbeaver.com/Main/main.html



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
 
post #4 of 5 (permalink) Old 08-18-2013, 10:32 PM
Senior Member
 
Join Date: Aug 2012
Location: Lost Angeles California
Posts: 203
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
When I changed mine after looking at it a few times I noticed the socket is already connected to the ballest but 'inverted'(?). Pulled that apart, connected a new bulb and was good to go. Thought I needed all those new bits as well but were already there.
bamboojackson is offline  
post #5 of 5 (permalink) Old 08-29-2013, 03:24 PM Thread Starter
Junior Member
 
Hansolo's Avatar
 
Join Date: Jun 2013
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by bamboojackson View Post
When I changed mine after looking at it a few times I noticed the socket is already connected to the ballest but 'inverted'(?). Pulled that apart, connected a new bulb and was good to go. Thought I needed all those new bits as well but were already there.
Just an update. I removed the whole HID system, it had lowbeam power going into the HID ballast. Once that was removed I bought a H4 adapter with pigtais off eBay and bought the OEM Honda bulb adapter which fits the standard H7 bulb. Works fine now.
Hansolo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome