Display and running issues - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-06-2014, 01:45 PM Thread Starter
GWS
Senior Member
 
GWS's Avatar
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 185
Mentioned: 1 Post(s)
Quoted: 13 Post(s)
Display and running issues

About a week ago I noticed that when I went to start the bike it lagged a bit and the trip meter on the display reset and it reverted over to the ODO. I thought nothing of it at the time, but it has started doing this frequently. After starting it again when it is warm it idles low at first, almost to the point of stalling, which never happened before. I was reading that this might be a battery issue, but there is not a whole lot of info.

About that same time I noticed that the bike started feeling sluggish, and I'm hearing more exhaust popping than usual. I have a PS3-USB, but I know nothing about them, and I'm thinking it is likely not causing the display issues.

Has anyone had similar issues? What do you guys think?

Sent from Motorcycle.com Free App
GWS is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-06-2014, 02:08 PM
Senior Member
 
COBRA90GT's Avatar
 
Join Date: Sep 2011
Location: HOCKEYTOWN ® MI
Posts: 1,291
Mentioned: 2 Post(s)
Quoted: 47 Post(s)
Sounds like a battery on its way out, especially with the trip meter resetting.

'06 Black/Metallic Gray RC51
-Competition Werkes FE w/
Clear Alternatives IT

'02 Silver/Black CBR 954RR
'11 Graphite Black CBR 1000RR (sold '15)
'08 Pearl Orange CBR 600RR (sold '11)
COBRA90GT is offline  
post #3 of 4 (permalink) Old 06-06-2014, 02:10 PM
Senior Member
 
Join Date: Jan 2014
Location: Dallas, Tx
Posts: 469
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
display is probably a weak battery. mine reverts back to odo reading too sometimes. i have the battery on a tender overnight, it displays whatever was last showing when i turn the bike off. still cranks the bike fine, but i'll probably get a new battery soon anyways.
thaddeus is offline  
 
post #4 of 4 (permalink) Old 06-06-2014, 02:20 PM
Senior Member
 
LDH®'s Avatar
 
Join Date: Mar 2010
Posts: 2,213
Mentioned: 7 Post(s)
Quoted: 331 Post(s)
That's a battery issue
LDH® is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome