Turn Signal Issues "HELP" - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-13-2012, 08:56 AM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: Parker,CO.
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Turn Signal Issues "HELP"

Have a 2002 SP2 that came with LED front markers that won't blink, I want the flush mounts instead of the stock stems. Any input on fixing the blinky blinky would be appreciated.
Thankx Marty
[email protected]
Thumperz52 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-13-2012, 09:38 AM
Member
 
Join Date: Aug 2011
Location: Orrington, Maine
Posts: 70
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Look for a "no load" electrontic flasher unit to replace the stock flasher unit.

Sean
Sport is offline  
post #3 of 5 (permalink) Old 05-13-2012, 10:03 AM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,461
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
Is the problem limited to one side, or do they not blink at all?
If not at all, then it could be the switch, wiring, or flasher relay.

If they only blink fast, then that's caused by insufficient current flowing through the flasher relay.
In that case your choices are to install load resistors, or replace the OEM (thermal) flasher relay with an electronic flasher relay.
SubSailor is offline  
 
post #4 of 5 (permalink) Old 05-13-2012, 10:35 AM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
Here is an old thread telling you more...

https://www.rc51forums.com/forums/sho...+flasher+relay



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #5 of 5 (permalink) Old 05-14-2012, 08:03 AM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: Parker,CO.
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
No blink at all so I'll start with a compatible relay(1st response) being that the rears are stock and the fronts are flush mount LED's. Thanks for the help!
Cheers M
Thumperz52 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome