fixed my bikes misterious electrical problem - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-30-2013, 12:04 AM Thread Starter
Senior Member
 
nwall1's Avatar
 
Join Date: Jul 2012
Location: houston tx
Posts: 265
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
fixed my bikes misterious electrical problem

So I decided to take off some plastics and start checking and cleaning some plugs and grounds ect. Turns out the plug that goes from the rectafire was completely melted. So I cut the melted plug off and had some connectors laying around so I fixed her up and now she starts every time without draing the batt. And now the trip we have planned to ride the twisted sisters in west texas in two weeks is a full go for me. Cant wait to get back out there
nwall1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-30-2013, 04:15 AM
Banned
 
Join Date: Dec 2011
Posts: 3,636
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Good stuff...now go flog that piggy!



nobody is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome