blinkers and brake light not working - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-20-2010, 11:05 PM Thread Starter
Senior Member
 
Join Date: Oct 2009
Location: Seattle, Wa
Posts: 140
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
blinkers and brake light not working

Hello everybody, I had a very minor lowside and now the turnsignals are not working, the horn is not working and the brakelight is not working. All were working fine before the accident. Any ideas?

Maybe it wasn't so minor if all this stuff stoped working. I took the switch gear apart to look for loose or broken conections but everything looked fine. Could it all be down to the flasher? It would seem to me that if it was a bad flasher than the horn and brake light would be fine. The bike has some janky wiring from previous owner(s), so I am afraid I might be opening a can of worms here.

Anyway, any help is much appreciated.

Mythic44
05 GSX-R 1000
mythic44 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-21-2010, 08:42 AM
Senior Member
 
DRFLGD's Avatar
 
Join Date: Jan 2009
Location: South Beloit, Illinois
Posts: 502
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I'd get all the body work off and start jiggling wires! After you check your fuses and relays! Look for the obvious first!
DRFLGD is offline  
post #3 of 5 (permalink) Old 07-21-2010, 02:53 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,461
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
Check if your 10A fuse D in the fusebox is blown.
It allows power to the horn, signals, and brake/tail light.
SubSailor is offline  
 
post #4 of 5 (permalink) Old 07-22-2010, 12:46 AM Thread Starter
Senior Member
 
Join Date: Oct 2009
Location: Seattle, Wa
Posts: 140
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Where is the fuse box on the SP1 located?

Mythic44
05 GSX-R 1000
mythic44 is offline  
post #5 of 5 (permalink) Old 07-22-2010, 01:06 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,461
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
Quote:
Originally Posted by mythic44 View Post
Where is the fuse box on the SP1 located?
Behind the left lower cowl, just above the coolant overflow tank.
SubSailor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome