clutch drag sp1 - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-17-2011, 12:47 AM Thread Starter
Junior Member
 
Join Date: Feb 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Post clutch drag sp1

hey guys I just picked up a 2000 sp1. I am having issues with a dragging clutch.

If I disengage the clutch and roll on the throttle the bike starts moving forward. I doubt this is normal. curious what is the main culprit for this on these bikes.

I do not have any shifting issues, the lever doesnt feel spongy, the clutch engages fine from a stop, the motor doesn't seem to labor when it is just idling nor will it walk forward when just idling.


im thinking lifter rod. maybe oil is too thick?

any help on this would be greatly appreciated!
a1maniac is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-17-2011, 08:42 AM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,461
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
It's normal behavior.
Mine does it as well and I have no problems at all with the clutch.
As long as your clutch line is bleed and the fluid good, it should be fine.
SubSailor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome