random blinker problems - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-01-2011, 09:18 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Arrow random blinker problems

hey guys, i've got an 01 here that's been kind of a wiring basketcase. My blinkers have not been working lately, i've checked all connections, but nothing is loose. When I turn the blinkers on, I can hear the relay clicking, however usually they don't work, or it will take anywhere from 5 seconds to a minute to start working. I'm thinking I need to replace the relay, however i'm not sure where to find one. The one I found on ebay seems to look the same, however it's for the SP2 models. Anyone have any ideas or know where I could find a relay? -Kris
Hail2theskins is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-01-2011, 09:23 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
www.rc51parts.com

As an ounce of prevention, which ever wire harness is butchered maybe buy a spare from Ben too.



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #3 of 6 (permalink) Old 10-02-2011, 10:58 AM
Member
 
Racer X's Avatar
 
Join Date: Apr 2010
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have the turn signal relay from my '00 SP1. I was working just fine when I converted the bike to the track. I'll sell it for $10 shipped.
Racer X is offline  
 
post #4 of 6 (permalink) Old 10-03-2011, 11:25 AM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
I had exactly the same issue with my relay. Apperently they can become tired and work, or not, at random. Cycle gear has the replacement and it's LED compatable, for $20.
It instantly brought my rear bulbs and front proton led's into perfect working order.

John, 2000 RC51 #000100

jondog9 is offline  
post #5 of 6 (permalink) Old 10-03-2011, 06:26 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for the reply guys. I've sent RacerX a PM to take his, hopefully this solves the problem. I'm also thinking about replacing the rear wire harness since mine is so butchered, but there are several different ones on RC51parts.com , anyone know which part number i need for an '01?
Hail2theskins is offline  
post #6 of 6 (permalink) Old 10-03-2011, 07:11 PM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
Quote:
Originally Posted by Hail2theskins View Post
Thanks for the reply guys. I've sent RacerX a PM to take his, hopefully this solves the problem. I'm also thinking about replacing the rear wire harness since mine is so butchered, but there are several different ones on RC51parts.com , anyone know which part number i need for an '01?
Ben knows. He runs RC51parts.com. just ask him.

John, 2000 RC51 #000100

jondog9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome