Indicator / Blinker problems - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-13-2009, 08:12 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Question Indicator / Blinker problems

Gidday all, stumbled across the forum. Looks like a good source for info. Have a 2001 SP1 which used to be my track bike but have now put it back on the road and have got this frustrating problem with my blinkers. In the morning when it's cool the blinkers can take up to 20 seconds to start flashing. But in the afternoon or after the bike has warmed it takes less and less time for them to come on. Have replaced the indicator relay with a new OEM relay. The blinkers are standard, not LED. Very frustrating as I work in the city and it means I have no blinkers in the morning in peak traffic.

Anyone experienced this before?
CraigBa is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-14-2009, 04:46 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Problem fixed. Pulled the switch off the LH bar and gave it a clean and spray. All good.
CraigBa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome