Pit-Eck Undertail Issue - Turn Signal on tail stays lit - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-04-2009, 02:33 PM Thread Starter
 
Join Date: Sep 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Pit-Eck Undertail Issue - Turn Signal on tail stays lit

Installed a Pit-Eck brand undertail on my 04 RC51. Worked fine with no issues til i installed flush mount turn signals up front. Turn signals were crap and the right front signal actually melted about 10 mins after i installed it. From then on, the turn signal on the dash stays lit and the right rear bulb in my undertail stays lit with both the red running light and yellow integrated turn signal. The yellow turn signal still blinks when the signal is engaged.
I've removed the two front turn signals now and the problem still persists.
Any help would be appreciated. Thanks

-Bernard
theguiltypair is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-04-2009, 09:16 PM
Senior Member
 
Join Date: Jul 2009
Location: mASSachusetts
Posts: 131
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I had that problem when I tied in the ground wires for the turn signals in the rear. You don't need them. Just use the 3 wires for the tail/brake lights and only the pos wire(s) for the turn signals.

-Tony B
00 RC51
06 Evo IX
Ev0lv3d is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome