Fuel pump won't prime - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 04-23-2011, 11:32 AM Thread Starter
Junior Member
 
Join Date: Dec 2010
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Fuel pump won't prime

I had a question I couldn't find an answer to by searching that I was hoping to get some advice on.

I am in the middle of trying to sell my '05 and this morning when I tried to start it up to ride it to work the furl pump won't pressurize! Classic! Just what you want when trying to sell a bike! Anyway, I had the fairings off last week to change the oil and I am going to check all of the connections to the pump and battery this weekend. Is there aything else I should look at? Are the pumps themselves prone to going out? I know the pump is in the tank, do the wires going to it just come out of the bottom of the tank or are they off to one side or another (ie, what is the easiest way to get to them?)?

Any advice is really appreciated! Also, if anyone wants to buy an immaculate '05 with a recently sorted fuel pump issue please let me know!

Last edited by Kikemon; 04-23-2011 at 11:33 AM. Reason: can't spell!
Kikemon is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-23-2011, 03:59 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
Bank angle senso plugged in??

Here is a link to try:

https://www.rc51forums.com/forums/sho...uel+pump+prime



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #3 of 9 (permalink) Old 04-23-2011, 07:56 PM Thread Starter
Junior Member
 
Join Date: Dec 2010
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for the great link!
Kikemon is offline  
 
post #4 of 9 (permalink) Old 05-24-2011, 01:20 PM Thread Starter
Junior Member
 
Join Date: Dec 2010
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Just in case someone else happens to have this problem and searches and finds this thread, I thought I'd tell about the conclusion. It ended up being dirty contacts on the kill switch. It was in intermittent problem and therefore hard to diagnose. To show it was the kill switch I turned the ignition on during a period when the bike was broken and the pump wasn't cycling. I switched the kill switch on and off quickly a few times which caused the fuel pump to turn on. I took the switch apart and cleaned with electrical contact cleaner and it has been fine since.
Kikemon is offline  
post #5 of 9 (permalink) Old 05-25-2011, 07:29 PM
Site Sponsor
 
RC51parts.com's Avatar
 
Join Date: Apr 2009
Location: NY
Posts: 332
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Wow... odd that the kill switch would be that dirty, but it happens. Thanks for the resolution.
RC51parts.com is offline  
post #6 of 9 (permalink) Old 06-20-2011, 02:14 AM
Junior Member
 
Join Date: Jun 2011
Location: Colorado
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Very 1st Post

I had the same problem. So, I came to this forum. After hours of work I got it all back together and-nothing. The clock wound twice, which I had never seen it do, and the fuel pump didn't prime. Then it would crank but not start. I started it twice earlier to bleed the cooling system so I was stumped and bummed. Evidently I pushed the kill switch putting on all the body work. Thanks for the info/help.
Kevin
Kevin Dean is offline  
post #7 of 9 (permalink) Old 06-21-2011, 06:09 AM
Lifetime Premium
 
erbgottie's Avatar
 
Join Date: Aug 2009
Location: Dayton, VA
Posts: 365
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Damn kill switch, same problem happened here................used to cut off and on for me bout 10k miles ago.....glad you figured it out............if you would like to donate that bike to the Erbgottie Donation Foundation all items are appreciated

2003 Honda RC51 - 46K+
----------------------------------
PCIIIr, SATO low mount C/F, hotbodies undertail, SATO F/S, CRG shorty BRK & CLTCH levers, Magical Racing C/F speedo cover and rear hugger, HRC clutch & F Brake sock covers, Galfer SS lines all around, pair valve mod
erbgottie is offline  
post #8 of 9 (permalink) Old 06-22-2011, 11:02 PM
Junior Member
 
Join Date: Jun 2011
Location: Colorado
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Donations

Damn kill switch is right. I hit it riding one time and spent 20 minutes figuring that out. I still don't know how I hit it. You'd think I would have learned from that one.

I think I'll keep it for a while but thanks for the opportunity
Kevin Dean is offline  
post #9 of 9 (permalink) Old 06-23-2011, 01:20 AM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
Quote:
Originally Posted by RC51parts.com View Post
Wow... odd that the kill switch would be that dirty, but it happens. Thanks for the resolution.
Thats not the first one I have heard of...One case had the pad on the small pc board burt off

That mechanic was pissed and relieved at the same time as he had ran out of time "according to the book" and was finishing it pro bono.

I am glad the conclusion was posted.

You have any key chains made up yet there Mr. Parts Guy??? One of those would be right tasty and great advertisement!



The very first schoolbook that was written had God all over it. --Dave Mustaine

Last edited by madbuyer; 06-23-2011 at 01:35 AM.
madbuyer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome