Need Plugs!!..Which ones??? - Honda RC51 Forum : RC51 Motorcycle Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-12-2009, 02:53 PM Thread Starter
 
Join Date: Feb 2009
Posts: 72
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Need Plugs!!..Which ones???

I'm going to change my plugs out this weekend, Just wondering which plugs would be the best to put in there! I have sato banzai's on there now and will have a PCIII with a dan kyle map installed this weekend too!
Hydroboy35th is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-12-2009, 04:01 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,468
Mentioned: 24 Post(s)
Quoted: 89 Post(s)
The old reliable NGK's are hard to beat.
Just be sure to replace them with the correct type and hear range.
The ones used on RC51's are the iridium type.
They come pre-gapped from NGK because the tip is very small and could be easily damaged.
So don't bother gapping them.
The iridium tipped plugs aren't cheap, but last a long time.

From the service manual, for temperatures above 41 Deg F.
'00-'06: (MSRP about $12.30 ea.)
NGK IFR9H-11
Denso VK27PRZ11

'00-'01: (MSRP about $7.50 ea.)
NGK FR9BI-11
Denso IK27C11

Last edited by SubSailor; 03-12-2009 at 04:11 PM.
SubSailor is offline  
post #3 of 15 (permalink) Old 03-13-2009, 03:48 AM Thread Starter
 
Join Date: Feb 2009
Posts: 72
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks man!, your always on top of stuff!
Hydroboy35th is offline  
 
post #4 of 15 (permalink) Old 03-14-2009, 02:38 PM
Banned
 
Join Date: Jan 2009
Location: Live Free or DIE
Posts: 427
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
yes, OEM

i do every 5k miles and a swap
Mrgrn is offline  
post #5 of 15 (permalink) Old 03-14-2009, 04:45 PM Thread Starter
 
Join Date: Feb 2009
Posts: 72
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I just changed my plugs and put a new battery in, And my bike STILL wont start...its a major disapointment!!
Hydroboy35th is offline  
post #6 of 15 (permalink) Old 03-14-2009, 08:23 PM
Banned
 
Join Date: Jan 2009
Location: Live Free or DIE
Posts: 427
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
is the fule pump priming?

check the kill switch, kick stand etc
Mrgrn is offline  
post #7 of 15 (permalink) Old 03-14-2009, 10:21 PM Thread Starter
 
Join Date: Feb 2009
Posts: 72
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The fuel pump did prime, that kickstand was up(its on a rear stand) in neutral, it sounds like it wants to start but no go. Could it be because its too cold?
Hydroboy35th is offline  
post #8 of 15 (permalink) Old 03-15-2009, 01:55 AM
Member
 
olred21's Avatar
 
Join Date: Oct 2008
Posts: 50
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
how old is the fuel, nething over a mo or so is too old, try fresh plugs, fresh fuel and a good battery, if no go you either have a sensor bad or a fuel issue
olred21 is offline  
post #9 of 15 (permalink) Old 03-15-2009, 09:09 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,468
Mentioned: 24 Post(s)
Quoted: 89 Post(s)
Well the first thing to check is any fault codes for the ECU.
Jumper the the service connector and turn the key on to see if you get any codes.
Just remember that it stores all the codes, so if there were any problems in the past, it will show those as well if they were cleared.
Count the blinks and we'll see what they result.
A 1.3 second long blink counts as a 10, so for example a long blink and one short blink would equal 11.
SubSailor is offline  
post #10 of 15 (permalink) Old 03-15-2009, 10:13 PM Thread Starter
 
Join Date: Feb 2009
Posts: 72
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks guys!..Strangest thing happend today, my buddy brought over his space heater we heated up the garage and got the bike pretty warm!,..then turned the choke on and it fired up FOR A SECOND, tried it again it and it wouldnt start, tried it again only this time he had the throttle open 1/4 turn it started up slowly but now its all good. I guess it wasnt getting enough air.
Hydroboy35th is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome