quickshifter problems - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-28-2013, 02:56 PM Thread Starter
Lifetime Premium
 
pei-twin's Avatar
 
Join Date: Mar 2012
Location: pei canada
Posts: 200
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
quickshifter problems

it is cutting the ignition at random times no matter how i adjust the linkage, it works great and shifts the bike like it should but randomly cuts around every 10-20 seconds. everything is mounted solid and its not vibrating. i wonder if there is any pc settings that would cause/fix this.

when i unplug the quickshifter the bike works great
pei-twin is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-28-2013, 05:34 PM
Banned
 
Join Date: Dec 2011
Posts: 3,636
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Could it be just a bad quick shifter? As a process of elimination you've already determined it may be a bad unit. Can you borrow another to confirm? I bet you could, I know in this neck of the woods I could talk to a couple shops around here and find what I'm looking for.

Good luck and keep us posted...



nobody is offline  
post #3 of 6 (permalink) Old 04-28-2013, 06:43 PM Thread Starter
Lifetime Premium
 
pei-twin's Avatar
 
Join Date: Mar 2012
Location: pei canada
Posts: 200
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
ya i looked, i seem to be the only one around here running one :s next step is getting ahold of dynojet but thats like pulling teeth
pei-twin is offline  
 
post #4 of 6 (permalink) Old 04-29-2013, 02:24 PM
Senior Member
 
wingnutt's Avatar
 
Join Date: Nov 2012
Location: Maple Plain Mn.
Posts: 1,327
Mentioned: 3 Post(s)
Quoted: 58 Post(s)
The pressure transducer is made by a company called translogic.

You can obtain further information regarding Translogic products by contacting your Translogic Systems Ltd dealer:- CONTACT TRANSLOGIC SYSTEMS

Last edited by wingnutt; 04-29-2013 at 02:27 PM.
wingnutt is offline  
post #5 of 6 (permalink) Old 04-29-2013, 03:12 PM Thread Starter
Lifetime Premium
 
pei-twin's Avatar
 
Join Date: Mar 2012
Location: pei canada
Posts: 200
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Thanks Wingnutt i'll give that a try
pei-twin is offline  
post #6 of 6 (permalink) Old 05-16-2013, 02:58 AM
Member
 
Join Date: Jan 2011
Posts: 66
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I also had problems with my quick shifter, like yours.
after 3 hours of work i finally got it. my quickshifter was not well mounted, if you wanna explain your problem more precisely, maybe i could help you.
in my case it rev limited constanly at 5000rpm.
sorry for my bad english
road-runner is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome