Help!!! Speedo quit working - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-12-2013, 09:03 AM Thread Starter
Member
 
datdude77's Avatar
 
Join Date: Mar 2013
Location: Florence KY
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Help!!! Speedo quit working

I changed my oil last night now for some odd reason my complete display will not light up but the highbeam indicator works. Any ideas to fix this?
datdude77 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-12-2013, 03:15 PM
Senior Member
 
Join Date: Oct 2008
Location: Orange County, Southern California
Posts: 359
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
maybe a blown 10 fuse under the left side fairing.........

ARSEY51
ARSEY51 is offline  
post #3 of 6 (permalink) Old 06-12-2013, 04:25 PM Thread Starter
Member
 
datdude77's Avatar
 
Join Date: Mar 2013
Location: Florence KY
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
thank you. Will give it a shot on friday when i get another day off.
datdude77 is offline  
 
post #4 of 6 (permalink) Old 06-12-2013, 08:35 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,460
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
Check 10A Fuse E in the fuse box (behind lower left cowl).
SubSailor is online now  
post #5 of 6 (permalink) Old 06-13-2013, 04:37 PM
Lifetime Premium
 
Polarbear's Avatar
 
Join Date: Feb 2012
Location: scotland, UK
Posts: 1,108
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
any update on this?

Honda SP1.5 owner
Polarbear is offline  
post #6 of 6 (permalink) Old 06-15-2013, 11:44 PM
Member
 
Join Date: Feb 2013
Location: Delaware
Posts: 48
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If it's that fuse, your tail light will also be out. Brake light and turn signals will work but the always-on tail light won't. Mine blew yesterday lol

2003 SP2
Used to have Kwaks, but they're gone
RememberTheMallamo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome