Ring in Satos - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-12-2013, 05:46 PM Thread Starter
Senior Member
 
Join Date: Sep 2013
Location: Moncton, NB
Posts: 213
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Ring in Satos

So, wtf is up with the ring at the exhaust exit point on Sato low mount. Is this normal? My friend is saying engine problems.
penn542 is online now  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-12-2013, 05:57 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
?? pictures please



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #3 of 7 (permalink) Old 10-12-2013, 06:57 PM Thread Starter
Senior Member
 
Join Date: Sep 2013
Location: Moncton, NB
Posts: 213
Mentioned: 0 Post(s)
Quoted: 7 Post(s)



The left can has the carbon/whatever and right can is clean.
penn542 is online now  
 
post #4 of 7 (permalink) Old 10-12-2013, 07:04 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
This is typical of Sato exhaust, no worries. Enjoy the best pipes for the RC and tell your friend to leave the engineering to the professionals



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #5 of 7 (permalink) Old 10-12-2013, 07:06 PM
Lifetime Premium
 
James_03_rc's Avatar
 
Join Date: Sep 2010
Location: Newport NC
Posts: 2,697
Mentioned: 5 Post(s)
Quoted: 80 Post(s)
Thats the muffler bearing

Satos are like that. There is a cone inside the one can.

I believe that it is to balance out the pressures.

James

Sent from Motorcycle.com App
James_03_rc is offline  
post #6 of 7 (permalink) Old 10-12-2013, 07:08 PM
Lifetime Premium
 
James_03_rc's Avatar
 
Join Date: Sep 2010
Location: Newport NC
Posts: 2,697
Mentioned: 5 Post(s)
Quoted: 80 Post(s)
James_03_rc is offline  
post #7 of 7 (permalink) Old 10-12-2013, 08:13 PM Thread Starter
Senior Member
 
Join Date: Sep 2013
Location: Moncton, NB
Posts: 213
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Fhew! I think I had a heart murmur there for a second. I never thought to look, but after having the motor stop when riding lately, I thought this was a symptom. So, went for another ride today and after 3-4km motor dies when I punch it. This happened every 300-500m after this issue. I waited on the side of the road for 45min waiting for my buddy to come by with his trailer and he ran into something, so I started the bike and made it home after 3 km. I have absolutely no problems with the bike until I took the rear cowl and undertray off, as well as, install the proton flashers. Everything looks like it is hooked up in order. I will be bringing the bike to the shop Monday. More to follow.
penn542 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome