04 RC51 Missing at mid RPM's - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-13-2014, 05:35 PM Thread Starter
Member
 
Join Date: May 2014
Posts: 31
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
04 RC51 Missing at mid RPM's

Hello I've had my 04 RC51 (Sato exhaust and PCIII) for about a month now and it's been running great up until today. I was riding up a tight curvy road, riding pretty hard, it's still stock gearing so I was having to go from first to second quite a bit since the road is pretty tight.
I got on it pretty hard to pass a car then had to downshift to prepare for a curve, a little further up the bike started acting like it was flooding sort of then it settled out. Then I noticed it had a really bad miss when I hit about 6500 RPM, it would almost cut out kind of like hitting a rev limiter. It run fine on the way home as long as I didn't rev it high, but if I reved it up to about 6000 or 6500 it would miss really bad.

Any idea what would cause this?
Dano is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-13-2014, 05:53 PM
Lifetime Premium
 
James_03_rc's Avatar
 
Join Date: Sep 2010
Location: Newport NC
Posts: 2,697
Mentioned: 5 Post(s)
Quoted: 80 Post(s)
James_03_rc is offline  
post #3 of 7 (permalink) Old 06-13-2014, 08:52 PM Thread Starter
Member
 
Join Date: May 2014
Posts: 31
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Thanks for the suggestions James, I didn't have time to mess with it today but I'll check a few things out and post back what I find.
Dano is offline  
 
post #4 of 7 (permalink) Old 06-14-2014, 07:34 AM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
See here for illustration

https://www.rc51forums.com/forums/sho...sure+Regulator



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #5 of 7 (permalink) Old 06-14-2014, 01:08 PM
Senior Member
 
Join Date: May 2011
Location: Griffin, GA
Posts: 317
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Usually going to be fuel issues or ignition, check fuel pressure and flow test it, pull a spark plug see what it looks like, spin the bike over, see if it has a bluish spark.

04 Nicky
Jardine slip ons
520 conv. 15/40 RK quick accel kit
RickyBobbyv8 is offline  
post #6 of 7 (permalink) Old 06-15-2014, 01:16 PM Thread Starter
Member
 
Join Date: May 2014
Posts: 31
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Well I finally got a chance to get back on my bike today. I rode it down the road and it seems to be running fine now, run it up to 9k and it didn't miss at all.
Possibly the the FPR is starting to go bad? Do they usually show symptoms when they get hot?
Thanks for replies and all the info guys.
Dano is offline  
post #7 of 7 (permalink) Old 06-15-2014, 06:13 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
It can be sporadic at first but nothing to let go for long. Buy two as these are right handy to have around for future.



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome