Fitment issues with ebay radiators - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-09-2015, 01:36 AM Thread Starter
Junior Member
 
driftbandit's Avatar
 
Join Date: Dec 2014
Posts: 11
Mentioned: 1 Post(s)
Quoted: 2 Post(s)
Fitment issues with ebay radiators

Just picked up another SP1, but it has the notorious left hand radiator leak. The seller, however, included a pair of new ebay GPI radiators (I plan on running these short term).

After removing the factory radiator and attempting to install the ebay ones, I discovered (surprise) the thermo switch is too big for the port on the new one. Also the mounts for the fan are off a bit but I can work that part out.

Has anyone here come across this issue? What should I do about the switch? Drilling and tapping the port seems like a pain in the butt due to the diameter of the switch. Is there another switch that would fit? I normally avoid the ebay crap, but they're already available and my bike is down which is driving me bonkers. Any input is appreciated.
driftbandit is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-10-2015, 09:51 AM
Senior Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Quoted: 20 Post(s)
damn.. that sucks.. I was thinking about buying a set of these. is it at all possible he purchase.. and gave you the wrong one?
polivo1 is offline  
post #3 of 5 (permalink) Old 04-10-2015, 10:09 PM Thread Starter
Junior Member
 
driftbandit's Avatar
 
Join Date: Dec 2014
Posts: 11
Mentioned: 1 Post(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by polivo1 View Post
damn.. that sucks.. I was thinking about buying a set of these. is it at all possible he purchase.. and gave you the wrong one?
It's possible they may have shipped the original owner the wrong radiators, but the guy ordered the right one's. He showed me the invoice for SP1 radiators.

Although I'm pretty sure they are the correct pair because there's no port for a thermo switch on the SP2 radiators which mine has. Also, the right side radiator has no fan mounts, which is also correct for an SP1 radiator.

I actually broke out the ol' tap and die set last night and modified the ebay radiator to work. I also had to modify the fan mounts as the spacing was off a lot. So far, no leaks, and the bike is running much cooler! Then again it's only been a day.........

My advice: If you own a drill, a dremmel, and know how to use a tap set, then these radiators are ok to buy. Seem ok so far. If you have the cash, from what I've read according to some forum members on here and speedzilla, the front mount kit from Tyga USA is incredible and includes oil cooler.

Last edited by driftbandit; 04-10-2015 at 10:14 PM.
driftbandit is offline  
 
post #4 of 5 (permalink) Old 04-10-2015, 10:26 PM
Senior Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Quoted: 20 Post(s)
Quote:
Originally Posted by driftbandit View Post
It's possible they may have shipped the original owner the wrong radiators, but the guy ordered the right one's. He showed me the invoice for SP1 radiators.

Although I'm pretty sure they are the correct pair because there's no port for a thermo switch on the SP2 radiators which mine has. Also, the right side radiator has no fan mounts, which is also correct for an SP1 radiator.

I actually broke out the ol' tap and die set last night and modified the ebay radiator to work. I also had to modify the fan mounts as the spacing was off a lot. So far, no leaks, and the bike is running much cooler! Then again it's only been a day.........

My advice: If you own a drill, a dremmel, and know how to use a tap set, then these radiators are ok to buy. Seem ok so far. If you have the cash, from what I've read according to some forum members on here and speedzilla, the front mount kit from Tyga USA is incredible and includes oil cooler.

great to hear! So, these ebay rads are much cooler tha what was stock? What were your temperatures before? and after? Im thinking of buying a set.. and doing the spal pusher mod this winter.
polivo1 is offline  
post #5 of 5 (permalink) Old 04-10-2015, 10:38 PM Thread Starter
Junior Member
 
driftbandit's Avatar
 
Join Date: Dec 2014
Posts: 11
Mentioned: 1 Post(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by polivo1 View Post
great to hear! So, these ebay rads are much cooler tha what was stock? What were your temperatures before? and after? Im thinking of buying a set.. and doing the spal pusher mod this winter.
Temperatures are now much more stable and lower. Although this issue may have been exacerbated by the fact my stock left side radiator was junk. Several repairs, leaking, bent. I live near the coast in CA. During spring my temps were around mid 180's on the highway, while temps rose fairly quickly to the 200's in traffic.

Now highways are low 170's, and in traffic I approach low 200's but temps are more stable.

I have no experience with the fan mods (I know there's a few), but it sounds like you have a solid plan!
driftbandit is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome