Fuel pump primes sometimes ....Help - Honda RC51 Forum : RC51 Motorcycle Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 05-31-2015, 08:50 PM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Fuel pump primes sometimes ....Help

I have a 2001 RC and one day I came out to start the bike , I did not hear the fuel pump prime . I pushed the starter switch back and forth and it primed ! It started to where i needed ro push the switch 15 to 20 times to hear it finally prime ! I purchased a new oem switch and it does the same thing . Any suggestions guys ?
RC51 RIDER is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 06-01-2015, 12:42 PM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
Fuel pump relay and bank angle relay would be my first suspects.
Bank angle sensor and kickstand switch could also give you the same problem.

John, 2000 RC51 #000100

jondog9 is offline  
post #3 of 21 (permalink) Old 06-01-2015, 02:58 PM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
I did check the fuel cutoff relay, and the bank angle sensor relay, both have good continuity going to them, and they both click when you turn on the ignition !
RC51 RIDER is offline  
 
post #4 of 21 (permalink) Old 06-01-2015, 02:59 PM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
When I get home tonight I will check the kick stand switch also....
RC51 RIDER is offline  
post #5 of 21 (permalink) Old 06-01-2015, 03:37 PM
Member
 
Join Date: Sep 2014
Posts: 98
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
my fuel pump prime problem turned out to be a crappy connection through the pump. Theres a brass rivet underneath that green exoxy stuff. I had to re tighten the connection and re epoxy it. Not fun. Nor did I have confidence its not going to loosen up again and leave me stranded somewhere.
RC51Pilot is offline  
post #6 of 21 (permalink) Old 06-01-2015, 04:28 PM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
As a precaution, I did order a new fuel pump, fuel filter, and in new oem starter switch ! However I've been told if the fuel pump primes then that's not a bad fuel pump !
RC51 RIDER is offline  
post #7 of 21 (permalink) Old 06-01-2015, 08:59 PM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
The fuel pump is one of the last things on my list. So many other things that are tied to it that need to be checked first.
Did you try swapping the Highbeam relay. Put the fuel cut relay into the highbeam relay and cycle the highbeam a few times. Same works with the bank angle relay.
Pilot has a good point about connectors. There's a connector on the left side near the gas tank hinge that should be checked too. As I recall, it's a 3P connector.

John, 2000 RC51 #000100

jondog9 is offline  
post #8 of 21 (permalink) Old 06-02-2015, 12:14 PM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
I got home last night and lifted the tank

I checked the fuses on the left side of the bike- there -Good

I checked the bank angle relay and the fuel cut relay there - Good

I checked the high beam on my bike it's -Good

I checked for any loose connections under the tank and by the fuel pump and also for any pinched wires were the tank pivots there - Good

When I lifted the tank there was very little gas in it , would that make the fuel pump not prime ?
RC51 RIDER is offline  
post #9 of 21 (permalink) Old 06-02-2015, 12:26 PM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
I did check the 3 pin connector on the left side of the bike , I pulled it apart and applied dielectric grease . Any other suggestions guys ?
RC51 RIDER is offline  
post #10 of 21 (permalink) Old 06-04-2015, 12:28 AM Thread Starter
Member
 
Join Date: Apr 2015
Posts: 40
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
So I'm out in the garage tonight with my girlfriend looking over the bike and she says why don't you for giggles switch the headlight relay and the bank angle relay! You can really feel the fuel cut off relay when the Fuel Pump comes on intermittently and very little with the bank angle relay ! So I did that and now you can feel both really click and the fuel pump primes like a mofo! I tried it for 45 min intermittently on and off and it primed everytime ! I HOPE THIS WAS MY ISSUE I'm ordering two more relays just in case and I'll put a picture up on Amazon if anybody else wants to order them also
RC51 RIDER is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome