Speedo reading 0mph - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-13-2015, 09:04 AM Thread Starter
Senior Member
 
kmblackbear06's Avatar
 
Join Date: Jun 2014
Posts: 128
Mentioned: 7 Post(s)
Quoted: 12 Post(s)
Garage
Speedo reading 0mph

So my speedometer has just recently started acting up just before I took it to go get inspected. Running the bike low speed (1st 2nd gear) gentle shifting/ mostly staying under 5K rpm at max and the speedo works (most of the time)... Highway speed 70+mph and it almost always reads 0mph. When I fall back down to 30mph or so it starts reading again. But it's so inconsistent and random I'm thinking it may be a look/bad wire or a poor connection. Anyone else have this issue? I'd love to trouble shoot it and hopefully take care of the issue without spending an arm and a leg and tearing my bike apart again

Any help is greatly appreciated.

-Kyle

'01 Red/Silver/Black RC51
-Ladybird GP exhaust with matching mids
-Samco hoses
-PC III USB
-Clear Stompgrips
-HotBodies FE
-Scotts Steering Damper
-DHC Carbon Hugger
kmblackbear06 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-13-2015, 11:57 AM
Member
 
Join Date: Feb 2013
Location: Calgary, AB, Canada
Posts: 36
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
There was a similar thread about this a few weeks back and I believe the cuplit was poor circuit board connection inside your actual cluster. The recommendation was to disassemble and cleab with alcohol. I have the same problem but won't be taking mine apart till winter. In the meantime I just have an idea of what rpm equals what speed.
JVR1 is offline  
post #3 of 3 (permalink) Old 07-13-2015, 01:59 PM Thread Starter
Senior Member
 
kmblackbear06's Avatar
 
Join Date: Jun 2014
Posts: 128
Mentioned: 7 Post(s)
Quoted: 12 Post(s)
Garage
Thanks, I'll give it a try and double check the connections too. I had no issues up until a week or two ago. I need to get mine fixed to get it inspected.
kmblackbear06 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome