Looking to buy. Speedo cluster not working. Everything else is fine - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-10-2015, 08:57 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Looking to buy. Speedo cluster not working. Everything else is fine

2001 SP1 with 48,000 km.

Always wanted one, and someone is willing to trade it for my snowmobile.

Anyways, it appears to be in perfect shape, but the cluster doesn't work.

Run, or is this a fixable issue?

Tail light works, so it's not the fuse. FI is working (of course).
iamcanjim is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-10-2015, 10:27 PM
Senior Member
 
Join Date: May 2012
Posts: 203
Mentioned: 1 Post(s)
Quoted: 25 Post(s)
I have seen lots on Ebay. But they are not cheap.
Fuzzuki is offline  
post #3 of 5 (permalink) Old 09-10-2015, 10:34 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I'm guessing it's an electrical issue not a cluster issue. But who knows.
iamcanjim is offline  
 
post #4 of 5 (permalink) Old 09-23-2015, 09:18 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Ok. I bought it (traded for it). 75,000 kms. Wouldn't start when I picked it up, but replaced spark plugs and away it goes. Has some sort of race clutch in it. Next issue was a bad fork seal, which with it sitting so long and then moved, got oil all over the front left caliper and rotor. Cleaned them and ordered new calipers. Now finding it brake light is on when the brakes aren't used, but off when the brakes are on. It's got one of those stupid aftermarket led tail lights as well as a tail tidy, so looks like I have to go through a bunch of wiring.
iamcanjim is offline  
post #5 of 5 (permalink) Old 09-24-2015, 03:21 PM
Senior Member
 
Join Date: May 2012
Posts: 203
Mentioned: 1 Post(s)
Quoted: 25 Post(s)
Easy fixes. Have fun with the bike. Good find.:heavy_check_mark:
Fuzzuki is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome