how do i replace my map sensor on an sp2? - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-12-2015, 01:13 PM Thread Starter
Senior Member
 
jgspecial's Avatar
 
Join Date: Jul 2015
Location: Dracut, Massachusetts
Posts: 233
Mentioned: 1 Post(s)
Quoted: 46 Post(s)
Garage
how do i replace my map sensor on an sp2?

how do i get to it? i cant find out enough info on the net to make me want to attempt it. one area shows the baro sensor on the snorkel another shows it near the throttle body. does anyone have pctures or at least can give me a breakdown on the easiest wy to replace it? the garage i went to said i have to replace it but they wanted to charge too much between the part and labor so i went the used route. any help would be much appreciated, thanks!!!!

lovin' my little torque monster.
jgspecial is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-12-2015, 01:27 PM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
Quote:
Originally Posted by jgspecial View Post
how do i get to it? i cant find out enough info on the net to make me want to attempt it. one area shows the baro sensor on the snorkel another shows it near the throttle body. does anyone have pctures or at least can give me a breakdown on the easiest wy to replace it? the garage i went to said i have to replace it but they wanted to charge too much between the part and labor so i went the used route. any help would be much appreciated, thanks!!!!
Have you tried removing and refitting the connector. Sometimes it just needs a good cleaning, dielectric grease and plug it back on.
Are you getting a code from the FI lamp?

Here's a downlaoadable manual. Go to section 5-14
http://www.rc51.info/index.php?page=service

John, 2000 RC51 #000100


Last edited by jondog9; 10-12-2015 at 01:29 PM.
jondog9 is offline  
post #3 of 8 (permalink) Old 10-12-2015, 01:49 PM Thread Starter
Senior Member
 
jgspecial's Avatar
 
Join Date: Jul 2015
Location: Dracut, Massachusetts
Posts: 233
Mentioned: 1 Post(s)
Quoted: 46 Post(s)
Garage
didnt even take it apart yet, thanks for the suggestions, ill probably look at it tomorrow.

lovin' my little torque monster.
jgspecial is offline  
 
post #4 of 8 (permalink) Old 10-12-2015, 05:19 PM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
I think you should spend a little time testing what you have before automatically replacing it with a used unit...

John, 2000 RC51 #000100

jondog9 is offline  
post #5 of 8 (permalink) Old 10-12-2015, 07:47 PM
Lifetime Premium
 
Join Date: Apr 2009
Posts: 1,858
Mentioned: 10 Post(s)
Quoted: 135 Post(s)
I can tell you that the MAP sensor is the same part on the intake and the throttle bodies, and they can go bad.
sbkdrew is online now  
post #6 of 8 (permalink) Old 10-12-2015, 09:56 PM Thread Starter
Senior Member
 
jgspecial's Avatar
 
Join Date: Jul 2015
Location: Dracut, Massachusetts
Posts: 233
Mentioned: 1 Post(s)
Quoted: 46 Post(s)
Garage
well im gettin a single long blink on the fi light the shop told me its the bad part and they specifically said map sensor and not baro. its nice to know its a common part between the 2. my question is, is the one on the throttle body accessible from the inside of the airbox? im new to working on my bike, sorry for the newbie sounding question but you guys seem to be very helpful and nice from the others ive seen you help. as always, thank you for the responses!

lovin' my little torque monster.
jgspecial is offline  
post #7 of 8 (permalink) Old 10-12-2015, 10:43 PM
Lifetime Premium
 
madbuyer's Avatar
 
Join Date: Sep 2010
Location: Indy
Posts: 8,335
Mentioned: 17 Post(s)
Quoted: 226 Post(s)
Read the manual....you will need to remove the air box.



The very first schoolbook that was written had God all over it. --Dave Mustaine
madbuyer is offline  
post #8 of 8 (permalink) Old 10-13-2015, 09:42 AM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
SP1 you just need to lift the gas tank.
SP2 you need to also remove the airbox.

How long is that blink?
0.5 seconds = a short blink = 1
1.3 seconds = a long blink = 10

Sounds like you're on the right track with either the MAP or Baro.

Determine which code you actually have, then inspect the wires and clean the connectors.
Then clear the fault codes from the ECU's memory.
Then start the bike again and see if the code returns.
It may not.
If it does, then continue with the tests on page 5-14 and 5-15 of the service manual.

John, 2000 RC51 #000100

jondog9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome