RC51 Indicator constantly illuminated - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-24-2016, 03:02 PM Thread Starter
Junior Member
 
Join Date: May 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RC51 Indicator constantly illuminated

Hi all, I have a 2003 RC51, I've noticed that the right hand front indicator is constantly illuminated, all indicators appear to work correctly however when I cancel the switch for the right hand set the front right stays constantly illuminated could this be a bad connection or faulty relay? any advise would be much appreciated.
markymark is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-24-2016, 03:15 PM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,507
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
are they stock signals?

if that is the case you actually have a burned out running light on the left side.
Wibbly is online now  
post #3 of 6 (permalink) Old 05-24-2016, 04:39 PM Thread Starter
Junior Member
 
Join Date: May 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sorry I have just checked again and in fact both front indicators are illuminated when I turn the ignition on, however all 4 indicators work normally with the switch , but for some reason the two front indicators stay steadily illuminated (not flashing) its a stock bike with stock signals, could it be the relay?
markymark is offline  
 
post #4 of 6 (permalink) Old 05-24-2016, 05:29 PM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,507
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
no, they are intended to stay lit. the front signals have running lights built into them. they take a dual filament bulb
Wibbly is online now  
post #5 of 6 (permalink) Old 05-25-2016, 04:06 AM Thread Starter
Junior Member
 
Join Date: May 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thank you Wibbly, I have just purchased the bike and thought that maybe I had a problem, I live in the UK and so this is all new to me, our UK SP2's do not have the running/dual filament set up, thanks for clearing this up. Just one quick question, would it be okay to replace the bulbs with a single filament? or would I create a problem by doing so, i.e. would it throw up a dash warning light?
markymark is offline  
post #6 of 6 (permalink) Old 05-25-2016, 09:28 AM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,507
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
you can't use a different bulb, the sockets are different.

you could pull the wire for the running light out of the connector and insulate it though. iirc it's the blue or orange with the white tracer
Wibbly is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome