Is this PC3 installed correctly/wiring Question - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-02-2016, 07:53 PM Thread Starter
GWS
Senior Member
 
GWS's Avatar
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 185
Mentioned: 1 Post(s)
Quoted: 13 Post(s)
Is this PC3 installed correctly/wiring Question

I have been wondering for years if my PC3 was wired correctly. This is a black box (seen in photos) about 2"x4" in front of the PC that has wires in a black sleeve that are at least a foot longer than they need to be, so I am wondering if this is an add-on. Despite some odd looking wiring I have never had a problem with the bike, but I would really like to know if everything looks okay, or if I should do something. Let me know what you guys think.

This is the little black box.



This is the really long cord coming out of the black box:



This white plug is what the black box plugs into:



This green plug near the battery is not connected:






This is the PC3. The cord coming out of it goes up the left side of the bike and plugs in near the front of the motor. When I turn the bike on a light comes on.



This white plug near the tail lights is connected to a wire that is cut, and has electrical tape covering it:

GWS is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-02-2016, 08:15 PM
Lifetime Premium
 
Waldo's Avatar
 
Join Date: Aug 2009
Location: Boise Idaho
Posts: 861
Mentioned: 3 Post(s)
Quoted: 40 Post(s)
It looks like the black box is a speedo healer. Have no Idea if your PC3 is connected correctly to the injectors or not. I think that white connector is your license plate light.


Last edited by Waldo; 06-02-2016 at 09:41 PM.
Waldo is offline  
post #3 of 5 (permalink) Old 06-02-2016, 08:35 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,461
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
The green connector near the battery is your service connector.
SubSailor is offline  
 
post #4 of 5 (permalink) Old 06-02-2016, 09:44 PM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,503
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
as stated before

the mystery black box is a speedo healer. it's plugged in line with the speed pickup. the white plugs are the stock connectors, the green ones to to the healer

the green plug with nothing plugged in by the battery is the service connector. this is normal


the PC plugs in line with the throttle body connector, it's nearly impossible to mess up. make sure the black wire with a ring terminal in the PC harness is connected to battery negative.


the white plug at the rear of the bike is the license plate light connector. it looks like you have an after market setup so they probably just used the positive from the bike and a common negative. hence the use of only a single wire



any other questions?
Wibbly is online now  
post #5 of 5 (permalink) Old 06-02-2016, 11:28 PM Thread Starter
GWS
Senior Member
 
GWS's Avatar
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 185
Mentioned: 1 Post(s)
Quoted: 13 Post(s)
Thanks for the info! The. The black PC wire is connected to the negative terminal. Looks like everything was done properly.
GWS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome