Water in oil - Honda RC51 Forum : RC51 Motorcycle Forums
 1Likes
  • 1 Post By SubSailor
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-02-2017, 03:24 AM Thread Starter
Gaz
Junior Member
 
Join Date: Jul 2017
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Water in oil

Hi all,
I recently purchased rc51sp1 2000. Dropped the oil and it milky white. Dreaded Water and oil mix. But no oil or gunk in the rad, bit low on coolant but I could see it and I topped it up and no air bubbling back either to indicate head gasket when running if I'm lucky. Did engine flush and changed filter and let sit for 1/2 hour opened sump nut and 1/4 egg cup of pure green coolant ran out then the oil!! Could this be water pump mechanical seal? I'm hoping. No other leaks and starts fine. Or Any help much appreciated

Thanks Gaz
Gaz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-02-2017, 12:35 PM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,521
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
My suspicion would be the water pump.
Wibbly is online now  
post #3 of 4 (permalink) Old 07-02-2017, 12:48 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,468
Mentioned: 24 Post(s)
Quoted: 89 Post(s)
Do you spot any fluid residue on the ground near the front right of the engine where the water pump is located?
There is a hose that connects to a fitting that sits in the space between the water pump mechanical seal and oil seal.
Usually, if the mechanical seal is worn, you should see coolant residue from the hose, or oil if the oil seal is worn.
You may have to look inside the right cowl to check, but a leak this bad should be readily apparent from the hose.
Trace likes this.
SubSailor is online now  
 
post #4 of 4 (permalink) Old 07-02-2017, 04:50 PM Thread Starter
Gaz
Junior Member
 
Join Date: Jul 2017
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for the reply guys, no external leaks from the hose. I pulled the crank case of last night. The two steel stems that connect to the water pump with the o rings are extremely loose in the o rings and the crank case. They don't seem to have been sealing! Hopefully this might be it. But I will change all when I'm in here.
Gaz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome