Fi code issues - Honda RC51 Forum : RC51 Motorcycle Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 12-18-2012, 01:43 PM Thread Starter
Member
 
Join Date: Jul 2010
Location: Staten Island, New York
Posts: 94
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Fi code issues

Hey fellas, im having a problem with my SP2. I recently did some major overhaulin on my bike to create my version of the SP3. I am about 75% finished with my project. All that is left is to paint my race fairings and install my two 3in round headlights.

Today for the first time in about 3 months, I decided to fire up the bike. I could not before then because I have been working on it and everything was apart. The bike will start and run, however, I am getting some FI codes which in return are causing the bike to stall upon any revs. The bike idles fine and warms up fine but stalls out with any throttle pull. The codes I am getting are 8 short/1 long/1 short.

My recent project included the installation of an 05 CBR1000rr subframe, tail, and custom undertail exhaust. Needless to say all of my storage space disappeared and everything that was in the tail had to be repositioned around the bike so that it would all work.

Is there an FI code list for the RC51 or can anyone tell me what the codes me? The manual has nothing in it as I have read through it several times.
Your thoughts would be much appreciated.
LEDET409 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 12-18-2012, 02:18 PM
Lifetime Premium
 
Duckhunter's Avatar
 
Join Date: Oct 2009
Location: Victoria B.C Canada
Posts: 4,560
Mentioned: 13 Post(s)
Quoted: 162 Post(s)
Garage
hmmmm Subsailor???? Care to chime in ??? He is a know it all LMAO

-2001 Honda RC51 sp1 " Slightly Modified "
-2001 Honda 929RR Erion Edition
DuckHunterComposites
Duckhunter is offline  
post #3 of 11 (permalink) Old 12-18-2012, 02:27 PM
Member
 
Sniper's Avatar
 
Join Date: May 2011
Posts: 62
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
in the rc manual section 5 - 12, gives you all the fi codes.

short blinks are 1, long blinks are 10, followed but a few short ones. then a pause between the next code.

8 short is loose or poorly connect TP sencer
1 long (just 10)is the baro sencer, thats on the front of the snorkel or top of air box.

unless its 1 long 1 short making it 11 which would be loose or disconnected speed sencer/ short in circuit/bad sencer.

2002 Honda RVT1000 RC51

Facebook
Sniper is offline  
 
post #4 of 11 (permalink) Old 12-18-2012, 02:37 PM Thread Starter
Member
 
Join Date: Jul 2010
Location: Staten Island, New York
Posts: 94
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
When looking at the FI code as it blinks, it would show 8 short blinks, then a pause, followed by 1 long blink, then a pause, followed by 1 short blink. Hopefully that will better describe the issie.
LEDET409 is offline  
post #5 of 11 (permalink) Old 12-18-2012, 03:10 PM
Moderator
 
SubSailor's Avatar
 
Join Date: Oct 2008
Location: Sarasota, FL
Posts: 6,460
Mentioned: 24 Post(s)
Quoted: 88 Post(s)
Depending on interpretation, it could be FI code 8 (TPS - Throttle Position Sensor), 10 (BARO sensor), and 1 (MAP sensor).
Or 8 (TPS) or 11 (Speed Sensor).
It's all a matter of the length of the pause between the 10 and 1.

But, that 8 code is TPS, and that could be the reason your bike runs badly when the throttle is rotated.
The ECU uses a default value of 0 deg throttle opening if there's a TPS sensor problem.

I would double check the connect or is making good contact and the contacts aren't corroded.
If all looks ok, then go through the troubleshooting routine to check the TPS in the service manual on P. 5-20.
SubSailor is online now  
post #6 of 11 (permalink) Old 12-18-2012, 03:38 PM Thread Starter
Member
 
Join Date: Jul 2010
Location: Staten Island, New York
Posts: 94
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I dont understand it. I did not do anything to the bike put touch a couple of connectors underneath to move them around maybe an inch or two left and right just to see inside under the bottom of the tank. Now the bike runs with no problems. If it come back though, I will let you all know.

This bike is awesome but is so finicky in certain areas. At least that is what I have found since I have owned this the last three years.
LEDET409 is offline  
post #7 of 11 (permalink) Old 12-18-2012, 03:54 PM
Senior Member
 
kwtoxman's Avatar
 
Join Date: Oct 2012
Location: Canada
Posts: 2,141
Mentioned: 11 Post(s)
Quoted: 109 Post(s)
Quote:
Originally Posted by SubSailor View Post
Depending on interpretation, it could be FI code 8 (TPS - Throttle Position Sensor), 10 (BARO sensor), and 1 (MAP sensor).
Or 8 (TPS) or 11 (Speed Sensor).
It's all a matter of the length of the pause between the 10 and 1.
Not according to the manual. Error codes are shown ascending # order from the lowest #.
kwtoxman is offline  
post #8 of 11 (permalink) Old 12-18-2012, 04:00 PM
Lifetime Premium
 
MakisRC51's Avatar
 
Join Date: Jan 2012
Location: Korinthos, Greece
Posts: 3,239
Mentioned: 15 Post(s)
Quoted: 77 Post(s)
Quote:
Originally Posted by SubSailor View Post
Depending on interpretation, it could be FI code 8 (TPS - Throttle Position Sensor), 10 (BARO sensor), and 1 (MAP sensor).
Or 8 (TPS) or 11 (Speed Sensor).
It's all a matter of the length of the pause between the 10 and 1.
This is very true about the interpretation.
However, considering that the TPS fault code is valid, I would stick with the MAP sensor too which is also located on the throttle bodies and say that the TB's wiring loom is not properly connected to the main wiring harness or some connectors are corroded on the 14p connector on the LH side of the rear cylinder (as you ride the bike), under the tank (the large one).
If that's true the the 10 blink (1 long flash) stands for the BARO sensor which is located on the air duct in the front (behind the dash) and it's either its connector on it or under the upper cowl's LH side the 2p connector (Light green/Black wire and Yellow/Red wire) poorly connected.


My Íhlins Project: https://www.rc51forums.com/forums/showthread.php?t=6033
Quote:
Originally Posted by SubSailor View Post
Congratulation to MakisRC51 for winning the 2014 Bike Of The Year Contest!
MakisRC51 is offline  
post #9 of 11 (permalink) Old 12-19-2012, 08:10 AM
Junior Member
 
Join Date: Aug 2008
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
How about some photos of this SP3?
Hanberg[DK] is offline  
post #10 of 11 (permalink) Old 12-19-2012, 11:57 AM Thread Starter
Member
 
Join Date: Jul 2010
Location: Staten Island, New York
Posts: 94
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I plan on doing a full write up on my version of the SP3 when I am finished.
LEDET409 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome