FI light and engine stutter - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-31-2017, 11:21 PM Thread Starter
Junior Member
 
cam.collins's Avatar
 
Join Date: Mar 2014
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
FI light and engine stutter

Hey guys, I have a 2002 SP2 with ~32k miles. Only aftermarket I have is a two brothers slip on. I have the bike since 12k miles with no issues. Recently valve adjustment. Bike starts up great no issues. Rides great, feels fine and suddenly it?ll have a quick stutter and continue on like nothing is wrong. The FI light will kick on for 1 second and that?s it and never returns until it stutters again. It stutters short quick and not very often. Happened about a week ago once and today it happened about 5 times in a about 75 miles riding. Manual sounds like it points to the BARO. Any more info on this or a different place to look? I?ve looked around here and most people seem to say there bike completely dies and mine doesn?t. Thanks!
cam.collins is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-31-2017, 11:59 PM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,522
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
check your battery terminal connections
Wibbly is online now  
post #3 of 7 (permalink) Old 11-01-2017, 12:23 AM Thread Starter
Junior Member
 
cam.collins's Avatar
 
Join Date: Mar 2014
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Wibbly View Post
check your battery terminal connections
I got maybe 1/8 turn on positive side, negative was tight
cam.collins is offline  
 
post #4 of 7 (permalink) Old 11-01-2017, 12:25 AM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,522
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
it could also be a circuit problem with the engine stop relay.

do you use the kill switch a lot?
Wibbly is online now  
post #5 of 7 (permalink) Old 11-01-2017, 12:41 AM Thread Starter
Junior Member
 
cam.collins's Avatar
 
Join Date: Mar 2014
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Wibbly View Post
it could also be a circuit problem with the engine stop relay.

do you use the kill switch a lot?
Yeah I do, probably a lot more than I should
cam.collins is offline  
post #6 of 7 (permalink) Old 11-01-2017, 01:13 AM
Senior Member
 
Join Date: Sep 2015
Location: Edmonton, AB
Posts: 1,522
Mentioned: 7 Post(s)
Quoted: 323 Post(s)
I'd take the switch apart and clean the contacts at the very least. Also pull apart and clean any electrical connectors along the way
Wibbly is online now  
post #7 of 7 (permalink) Old 11-01-2017, 07:22 AM
Senior Member
 
COBRA90GT's Avatar
 
Join Date: Sep 2011
Location: HOCKEYTOWN MI
Posts: 1,291
Mentioned: 2 Post(s)
Quoted: 47 Post(s)
Did this problem just start to appear after the valve check/adjustment or has it always been present ?

'06 Black/Metallic Gray RC51
-Competition Werkes FE w/
Clear Alternatives IT

'02 Silver/Black CBR 954RR
'11 Graphite Black CBR 1000RR (sold '15)
'08 Pearl Orange CBR 600RR (sold '11)
COBRA90GT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome