No crank, no lights, no fuel pump prime - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-21-2018, 10:51 AM Thread Starter
Junior Member
 
McCary04's Avatar
 
Join Date: Feb 2018
Location: Summerville GA
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
No crank, no lights, no fuel pump prime

Hi Guys, I have a bit of a head scratcher. I was riding my RC and everything was fine. I stopped to take a break, and when I started again I was coasting down a hill when I tried to start the bike. I realized that I still had the kill switch off, so I turned it on while the bike was still rolling. When I did the entire bike died. All of the lights went out, the gauges lost power, and the fuel pump stopped. I had to call a friend to bring a trailer to get the bike home. now here's the funny thing. Then you turn the key on nothing happens, no lights fuel pump or anything. If you unplug the headlight, the gauges power up, and all other lights on the bike work as they should, but still no fuel pump priming. None of the fuses are blown, and all of the relays have continuity, and switch on and off when powered with a Power Probe. I have taken the entire harness off of the bike, and removed the wrapping/loom and I cannot for the life of me find any shorted or broken wires.
McCary04 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-21-2018, 12:29 PM
Junior Member
 
Join Date: Jun 2016
Location: North of North Dakota
Posts: 16
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Sounds like a ground side issue. Not a short, but the ground circuit is open or high resistance some where.

I know this is vague but should not be too hard to check. Make sure all the ground connections are clean and tight and remember the frame is part of the ground circuit.

Good luck!
17left is offline  
post #3 of 3 (permalink) Old 02-21-2018, 03:25 PM
Super Moderator
 
YtseJam's Avatar
 
Join Date: Dec 2009
Location: Central California
Posts: 1,237
Mentioned: 3 Post(s)
Quoted: 18 Post(s)
Moved to Tech Talk...
YtseJam is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome