Bike wont rev - Honda RC51 Forum : RC51 Motorcycle Forums
 1Likes
  • 1 Post By Russ*Collins51
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-25-2018, 09:50 PM Thread Starter
Junior Member
 
Join Date: Aug 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Bike wont rev

I recently replace the fuel pump to tank seal. When I had the fuel pump out, it looked pretty bad. I replaced the in tank return line and the rubber baffle that the line goes in to. and the rubber lines in the tank. After reinstalling the pump, I noticed that the bike would only rev to 8,000 rpm at full throttle. After noticing the problem I have replaced the fuel filter, spark plugs, and fuel pressure regulator. None of them resolved the issue. I also disconnected the power commander to rule that out. It only seems to have this problem after about 100 miles on a tank, and only at full throttle. I think I'm just going to order a pump next unless someone has any other ideas.
randy218 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-26-2018, 08:50 PM
Senior Member
 
Join Date: May 2018
Posts: 125
Mentioned: 2 Post(s)
Quoted: 28 Post(s)
Did you use submersible tubing in the fuel tank ? Are you sure nothing is kinked ?
Red Flash is offline  
post #3 of 5 (permalink) Old 06-26-2018, 09:49 PM Thread Starter
Junior Member
 
Join Date: Aug 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I used all OEM hoses. Pretty sure nothing is kinked.
Attached Thumbnails
Click image for larger version

Name:	IMAG0718.jpg
Views:	31
Size:	93.1 KB
ID:	128121  
randy218 is offline  
 
post #4 of 5 (permalink) Old 06-27-2018, 07:01 PM
Senior Member
 
jondog9's Avatar
 
Join Date: Aug 2010
Location: Northern CA
Posts: 8,653
Mentioned: 15 Post(s)
Quoted: 317 Post(s)
Check your tank vent line is clear? Easy enough to just grab the end of it and blow through when the gas cap is open. Just don't confuse it with the bigger fuel overflow hose. I'm sure you saw it when you reinstalled the pump. Could be a dirty filter too.

John, 2000 RC51 #000100

jondog9 is offline  
post #5 of 5 (permalink) Old 06-29-2018, 05:40 PM
Lifetime Premium
 
Russ*Collins51's Avatar
 
Join Date: Dec 2017
Location: NorCal Foothills
Posts: 266
Mentioned: 2 Post(s)
Quoted: 26 Post(s)
When you said it only happens after putting 100 miles on the tank, this is the first thing that came to my mind

jondog9 likes this.

2002 SP2
2005 750 Katana
2000 KX-500
1984 VT500 Ascot
1977 RD-400

Nice Old Harley you got there! Mind if I kick it over?
Russ*Collins51 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome