2004 SP2 w/ PC3 & PV5 issues - Honda RC51 Forum : RC51 Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-09-2019, 11:48 AM Thread Starter
Junior Member
 
Paul Tardieu's Avatar
 
Join Date: Jun 2019
Location: Orlando
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
2004 SP2 w/ PC3 & PV5 issues

Good Afternoon Guys, I have a unique problem that I am unable to solve even with the help of DynoJet techs. I'll try to sum it up quickly.

I bought my 04' 3 years ago and the previous owner said he had a PC3 that went bad and he highly suggests I put one back on. So I purchased a PC5 and installed it.
I got 1 ride to test it and it made a big difference. I went home for riding gear and upon restarting the bike I didn't even get 4 houses down. The bike wouldn't go passed 3500 rpm.
It was acting like it hit a wall and wouldn't go passed it even with the throttle wide open. I ended up spending hours with DynoJet techs over the next couple days. We trouble shot
over the phone. Adjusted the throttle, idle and mapping values. It kept doing the same thing. When I plugged back in the factory plugs.... it runs fine. Reconnect the PC5 plugs and
the same issues. I mailed the PC5 to them, they tested it and it worked fine. They refunded me the money for it.

Fast forward a couple years till last week, I picked up a working PC3. I figure I'll give it a shot again with what was on the bike originally. Same damn issue. I even tested the PC3
an hour ago on another buddies RC51. I works fine on his. My bike is not altered in any way other than the basic mods. It has yosh slip ons, flapper valve mod, and soft rev limiter.


Power commanders are pretty plug and play. There is only a ground wire and the fuel connectors. Does anyone have an idea what could cause the PC3 & 5 to not work but the bike
operate fine with the factory plugs connected?
Paul Tardieu is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-27-2019, 10:42 PM
Junior Member
 
Join Date: Jan 2011
Location: eastern sierra california
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hello, where is the ground lead connected? I had a similiar problem with my PC3. Then i grounded directly t the battery and it work as designed.

SP2 track bike
rgv250f3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda RC51 Forum : RC51 Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome