RC51 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hello I've had my 04 RC51 (Sato exhaust and PCIII) for about a month now and it's been running great up until today. I was riding up a tight curvy road, riding pretty hard, it's still stock gearing so I was having to go from first to second quite a bit since the road is pretty tight.
I got on it pretty hard to pass a car then had to downshift to prepare for a curve, a little further up the bike started acting like it was flooding sort of then it settled out. Then I noticed it had a really bad miss when I hit about 6500 RPM, it would almost cut out kind of like hitting a rev limiter. It run fine on the way home as long as I didn't rev it high, but if I reved it up to about 6000 or 6500 it would miss really bad.

Any idea what would cause this?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Thanks for the suggestions James, I didn't have time to mess with it today but I'll check a few things out and post back what I find.
 

·
Registered
Joined
·
317 Posts
Usually going to be fuel issues or ignition, check fuel pressure and flow test it, pull a spark plug see what it looks like, spin the bike over, see if it has a bluish spark.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
Well I finally got a chance to get back on my bike today. I rode it down the road and it seems to be running fine now, run it up to 9k and it didn't miss at all.
Possibly the the FPR is starting to go bad? Do they usually show symptoms when they get hot?
Thanks for replies and all the info guys.
 

·
Premium Member
Joined
·
8,335 Posts
It can be sporadic at first but nothing to let go for long. Buy two as these are right handy to have around for future.:cool:
 
1 - 7 of 7 Posts
Top