RC51 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
469 Posts
Discussion Starter #1
Sp1. Full Jardine 2:1 pipe, deleted pairs, stock filters, new factory plugs, recent oil/filter change, new Dan Kyle 520 conversion. I've noticed 3rd-6th gear if I'm at a steady cruise and the go full wot the bike will kind of hesitate a few times then go. Runs good otherwise and pulls to respond strong. I'm leaning towards maybe the tune or a slightly worn clutch.

Any ideas?

Also, on the top of the snorkel, near the gauge, there is a hole there covered by tape. What goes there. And I'm missing the altitude sensor on the front of the snorkel. I got the bike this way. Guessing that's why the fi light stays on.
 

·
Premium Member
Joined
·
1,536 Posts
Yes, the missing MAP sensor will cause the FI light to activate. The tape covered hole on the snorkel sounds like a bad attempt at the flapper mod?
 

·
Registered
Joined
·
469 Posts
Discussion Starter #4
The way the hole is cut makes me think factory. It's a perfect circle with two small rectangular notches on either sides of the hole.

I plan on getting that sensor if I can find a used one. Not sure why it was missing. This is a former track bike
 

·
Registered
Joined
·
469 Posts
Discussion Starter #7
Ok so the big hole was for the flapper? I'll have to check to see if the vacuum line is plugged. But no the map sensor is missing, I already figured that's why the light has been on since I bought it.

Possible problem for my symptoms? The bike runs pretty damn good, just more of an annoyance. You can really tell in 5th or 6th gear cruising at half rpms and go full throttle. Stutters several times then goes.
 

·
Premium Member
Joined
·
2,697 Posts
I just reread your first post, if the clutch is worn and slipping, RPM will spike without speed increasing when you hammer on her. Without knowing more my guess is that it's a fueling issue causing the motor to load up and when you hit the throttle it takes a few moments to clear up. Unhook the PC and check your FPR for leaking into the small tube, it's been covered search for more information on that. Test ride and let us know if anything changes


Sent from Motorcycle.com App
 

·
Registered
Joined
·
469 Posts
Discussion Starter #10
No leaks at the fpr and what u said about clutch is what I know as well. Why I was thinking engine/tune. Plugs are 4k miles old filters look good. Guess I can pull the plugs and see if it's running too rich. I'll unhook the pc and test ride

Maybe worth mentioning, the Map says Jardine 2:1 kn filters with restrictors removed. My filters are def not kn guessing oem. So I suppose the tune could be sending more fuel than the bike needs
 

·
Premium Member
Joined
·
346 Posts
Why are you messing around? Fix the known issues first. Plug the flapper hole and replace the missing sensor. If it still has issues after these are done, then start looking at other things. Until you have done this you are wasting your time with the other things.
 

·
Premium Member
Joined
·
1,536 Posts
MAP sensor shouldn't cause a hesitation if I recall correctly. A few months back I sent my MAP sensor away and the bike still ran fine without it as I didn't change altitudes.

As for the flapper, remember it closes at around 5500rpm, then opens back up at about 6700rpm (which sounds like the mid range before you go wife open throttle)...this is probably the issue especially since tape is covering the hole.

Just my opinion without having the bike. Good luck and report back the results.
 

·
Registered
Joined
·
469 Posts
Discussion Starter #14
yes i plan on a custom tune. i hate when people ghetto rig shit. thanks guys.

weyrauch- for shits and giggles ill try a run with the tape removed. going to check to make sure the vacuum tank was removed and throttle body hose was plugged

thanks guys
 

·
Premium Member
Joined
·
4,617 Posts
If you have a working MAP sensor, sounds like you need that PC tuned.
 

·
Registered
Joined
·
469 Posts
Discussion Starter #16
the map is missing altogether. im on the hunt for one now. just finishing removing the rest of the flapper shit that the PO lazed out on. going to get the map sensor then have it tuned.

question: i noticed on rogue, they have dan kyles cover to go over the original diaphram. since i dont have the diaphram, what can i do with that hole?
 

·
Super Moderator
Joined
·
6,481 Posts
the map is missing altogether. im on the hunt for one now. just finishing removing the rest of the flapper shit that the PO lazed out on. going to get the map sensor then have it tuned.

question: i noticed on rogue, they have dan kyles cover to go over the original diaphram. since i dont have the diaphram, what can i do with that hole?
You could find a piece of thicker aluminum or steel strip, trim it, and use some small nylock nuts to fasten the cover plate by reaching into the snorkel to secure the screws.
That's what I did while I had my snorkel off, since the prior owner had removed the actuator and tossed it, then taped over the opening.
 

·
Registered
Joined
·
1,327 Posts
yes i plan on a custom tune. i hate when people ghetto rig shit. thanks guys.

weyrauch- for shits and giggles ill try a run with the tape removed. going to check to make sure the vacuum tank was removed and throttle body hose was plugged

thanks guys
I meant download a map from the internet and see if she runs better for now
 
1 - 19 of 19 Posts
Top