RC51 Forums banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
57 Posts
Discussion Starter #1
my bike took a dead beat while i was doing 60mph
downloaded the manual trouble shoot the best i could and concluded on:
:( Converter unit box is shot.
i get lights dash is fine
fuel pump primes(hums)
it turns over good
i have hooked up my battery is good
i got no spark at both plugs
my kick stand and kill switch are good
my angle sensor and shut off relay are fine
this is aggravating i wanna ride :mad::mad:
 

·
Premium Member
Joined
·
57 Posts
Discussion Starter #3
i do buy stuff on line but craig list from CA brings an uneasy feeling.
ive always been told u meet the person and do the exchange like that. im in louisiana nowhere close to this guy.
i would trust the forum members any day over a craighlist guy. the location says Menifee.
you familiar with this territory?
 

·
Premium Member
Joined
·
57 Posts
Discussion Starter #4
well jondog9 thanks for the link
i got this guys # we talked for a while he threw in a copy of the owners manual and i keep "hope" he is as honest as he sounded.
fellow biker had an accident and is needing $$
said would ship tomorrow. cross fingers
 

·
Registered
Joined
·
39 Posts
^^ So you're the one that took the CDI from me! Had a deal with him along with other parts, but do understand as he's needing money since he can't work. I'll let this one slip this time! :)
 

·
Premium Member
Joined
·
57 Posts
Discussion Starter #9
Oh what? Hope ur not down because of that box. I hate not being able to adjust and rigg things. This electric things going out are nightmares.
Oh and is not me alone i couldnt of done it without jondog9 lol ;)
 
1 - 10 of 10 Posts
Top