RC51 Forums banner
1 - 5 of 5 Posts

·
Registered
2006 RC51 SP2
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey all,

I’m hoping for some assistance. It is my understanding that RC51s usually run warm due to radiator placement, so this isn’t about that.

My issue is the electric gauge on the dash is reading off. It’s off by almost 40 degrees give or take. My understanding from the shop is they replaced the temp sensor but that didn’t fix the issue. See their explanation below:

“I got with the service guys and what they say they have been dealing with is the temperature gauge read out. When they turn the key on the gauge reads close to 107 degrees, and it should be at ambient temp. (Close to 70 degrees at the time) As the bike warms up, the gauge scales up & appears to be around 40 degrees too high also. They put an infrared gun to the radiators and the bike is running normal temps, so there is not a cooling problem or engine running too hot problem. They thought it was an easy fix replacing the temp sending unit, it was not. They are still trying to figure it out...”

Any thoughts on what it could be?

They are trying to correct this before I pickup the bike, so I figured if I could help with an answer, I will get the bike quicker :)

Thanks!
 

·
Registered
2006 RC51 SP2
Joined
·
8 Posts
Discussion Starter · #3 ·
Pages 455-456 in the shop manual procedure. Also check all of the wires to make sure they have not rubbed through on something. If you don't have the shop manual, there is a link on this site to download the PDF.
Thanks for the info. I’ll have to read up on it. I don’t have the bike, so I can’t do any testing myself right now. 😕
 
1 - 5 of 5 Posts
Top