RC51 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello fellow SP1 owners. I have recently purchased my 2001 model after it had been stood for approximately 3 years. Last week I rode the bike and it was lumpy but ran fine once the fresh petrol had flushed through. Yesterday the bike started fine and revs fine in neutral but once in gear and under load it feels like it's dropping onto one cylinder, the bike occasionally ran back onto two at over 5k revs but when back on 1 cylinder it's occasionally backfiring. I don't know which cylinder is dropping out as I'm riding it. I'm thinking plugs/ plug caps/ coils/ HT leads or possibly a injector. Any help/ suggestions would be greatly appreciated as this has tainted my experiences so far with my dream bike. Thank you.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #2 ·
Hello , taking the cheapest option first and ordered a pair of new plugs. Regards Andy.
 

·
Registered
Joined
·
1,715 Posts
a simiple test is to pull the vacuum line from the FPR and prime the pump a bunch of times, see if you get any fuel out of it.
 

·
Premium Member
Joined
·
2,383 Posts
Replace FPR, common fault. More so if the bike had been brought back from sitting
 

·
Registered
Joined
·
1,715 Posts
did you test your current one? i explained how to do it. it takes 2 minutes to lift the tank and check.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #15 ·
No not had chance yet as working nights this weekend.
Hello Wibbly, I've turned the ignition on and off numerous times to prime the pump as suggested and no petrol appearing at FPR vent pipe. Regards Andy.
 
1 - 15 of 15 Posts
Top