RC51 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
03 sp-2, on a ride the other day i was sitting at the light and idle dropped and eventually stalled, it started right up a off i went but, riding on the freeway at 70-75mph i felt like someone was behind me giving a slight tug on the rear, nothing major but concerning non the less, i got home and ran a code scan with the FI light and got 4 codes, air censor on the airbox, the TP censor, the baro sensor or bad pulse generator, so.............every test show they are good so i have to test ECM, my question is two part, anyone have this issue with ECM OR what are the possibility that the powercommander is causing this issue? gona run more diagnostics but just would appreciate some feed back
thanks
 

·
Premium Member
Joined
·
3,239 Posts
After eliminating the PC, check the grounds........too many fault codes can be caused by loosen battery terminal or corroded grounds.

Unplugging and plugging back on a connector usually corrects contact problems but using a smudge of dielectric grease between them helps a lot more.
 

·
Super Moderator
Joined
·
6,481 Posts
Also, clear the old FI codes.
The ECM stores all detected faults, so by clearing the stored codes, you won't be mislead by a past event. All faults stored afterwards will be current.
 

·
Registered
Joined
·
8,663 Posts
Fair Oaks, huh?
I live in Roseville.

Definitely unhook the PC and clear all the codes.
Then fire the bike up and go for another ride and see what codes show up, if any.

Kinda sounds to me like you might have a bad fpr, and all those codes are old.
I'd be glad to visit you and help if it gets to that.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I'll be looking into all the suggestions with fingers crossed, thank you everyone for the input very much appreciated,
jondog9 if i need help I'll be looking you up thank you for the offer.
if all works I'll be riding to laguna motogp and not driving
thanks everyone
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
unplugged commander and cleared all codes and went for a ride around town and freeway and no codes came up upon checking again, i think i'll hook up commander and go for a ride and see if it happens again, thanks everyone for the input
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
jondog9,
im not sure what you mean by fpr, it's an acronym for what?
also what kind of weekend riding do you do? it does get kinda mundane at time riding and doing events solo. if you want to talk more i'll send you my #
thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
jondog9,
im not sure what you mean by fpr, it's an acronym for what?
also what kind of weekend riding do you do? it does get kinda mundane at time riding and doing events solo. if you want to talk more i'll send you my #
thanks
 

·
Registered
Joined
·
8,663 Posts
Weird, I thought I posted on this thread last night....
Anyway, fpr is fuel pressure regulator. They're a common failure.
Lift the tank, look under the back of the airbox for the fpr, pull the small vac hose off the regulator, then turn the key to on so the pump primes. watch for dripping gas.
I've heard reports from some on here that sometimes a bad regulator wont necessarily drip for this test. If your bike has sat for any length of time, it might be time to just replace it. Last I talked to Carmichael Honda, they had one in stock. about $50.
btw, they'll price match any other online Honda dealer. Ask for Matt.

Good chance I'll ride Sunday morning, early before it gets hot. If you're interested, shoot me your phone number in a PM here.
 

Attachments

·
Registered
Joined
·
8 Posts
Discussion Starter #13
fixed?

well after clearing codes on the ECM and reconnecting the power commander we rode to motogp without any issues, ran a code check when i got home and still no codes. so now i have an extra ECM im sending out to get flashed. i'm still wondering if code where there all along and just started acting up or if this just happened? all works great so far.
thanks to everyone for posting advise and ideas
 

·
Registered
Joined
·
63 Posts
Thumper:

Who flashes ecm's for the RC's? I had my '11 CBR's ecu reflashed by EcUnleased and since I have a spare for the RC I'd like to get it done too.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #15
i looked into the same company also but now i'm looking for a diff company, since i just started looking i haven't found one so if you find one let me know and ill do the same,
by the way ladybird exhaust? sweet, i'm running leos'
 
1 - 15 of 15 Posts
Top