RC51 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
i have a 00 rc and my fi light is on it blinks 1 time and has a 4 to 5 sec pulse then light up 1 time then a 4 to 5 sec pulse u get the point so i am thinking that 1 blink =map sensor.
does that sound right but the bike seems to run fine but hard to start and then some random stalling but with the bike running i unplug the map sensor and the bike idle like crap and stall ? any help would be good
 

·
Super Moderator
Joined
·
6,481 Posts
Well 1-long & 4-short blinks is a code 14, which indicates loose or poor connection on #1 injector on cylinder #2.
And 1-long & 5-short blinks is a 15 code, which is injector #2 on cylinder #2.

Troubleshoot the wiring and electrical connectors of both both injectors.
Then again, it could be an electrical problem with the injector itself.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
im only get 1 long blink and then it goes off for 4-5 sec then it starts over with 1 long blink
 

·
Super Moderator
Joined
·
6,481 Posts
Well a code 10 is a faulty BARO sensor (on the front of the snorkel), or related connector or wiring.
The engine will run, but will run worse the higher the altitude.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
so i got a new baro sensor (Same as map sensor) and pluged it in still cant get the fi light to go off it says if it blinks 20 times it did not erase ? mine blink more than 20 times ? idk anybody in ohio to help FI light driving me crazy
 

·
Super Moderator
Joined
·
6,481 Posts
Do you have the service manual in paper or electronic form?
If so, go to the troubleshooting section for code 20.

It could be a problem with the baro sensor connection, the ECU connectors, an insufficiently cleared EEPROM memory, or the ECU itself.
Run through the steps to try and isolate the problem.

You've gone from a code 10 to a code 20, so maybe something's up with the baro sensor connection.
 
1 - 6 of 6 Posts
Top