RC51 Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Last weekend i've notest FI light on when i was riding with high speed or revs.When i will switch off and switch on engine stop switch everything is fine.But only to the moment when i will go again on high revs.
Power is OK,engine run OK,bikeis SP1 with power commander 3,SP Engeenering big bore exhaust,no flap valve in air intake,no K&N,new spark plugs (becose i had probs in winter time under 5 degreese cos no back presure with this exhaust and plugs was dead after 2,3 rides)
Anyone had ideas whats wrong with my baby?:(
Manual saying something about short circuit or faulty ECM
 

·
Registered
Joined
·
8,655 Posts
Normally I would say to bypass the PowerCommander, and run only on the factory ECU. BUT, you mentioned a big bore exhaust? I'm assuming you mean a full aftermarket header system, like a Akrapovic or Jardine 2 into 1?
For sure your bike will run lean without the powercommander, so not sure this is the best idea, I'm just trying to eliminate the easiest possibility first.
Try it for just a little bit of a test to see if you still have your symptoms.
Hopefully SubSailor, Miller, LDH, or Madbuyer will be along shortly. They know way more than me about electrical.

edit: I see this is your first post. Welcome to the forum, hope we can help you get the problem solved.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Oh Well... Its my first post cos its my first problem with my babe and still learning what is what from this forum :D
I have big bore SP ENGENEERING exhaust like this one and i lost power to about 3000rpm cos no back presure and in winter time had many problems with spark plugs becose that.But i sort it by standard exhaust only for winter time.Now i put back on my carbon one :)
I have another one SP1 so i'm planning to change ECM unit and then we will see what is gonna b like on high revs :( Will let u know about results just in case someone else will have simmilar probs in a future :(
 

·
Premium Member
Joined
·
8,328 Posts
Define high revs please. (rpm range) Can you post up pictures of the old plugs?

Are you having temperature issues.


Lets start here....;)
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
When i change old spark plugs i remember they was dry but black.They should b like coffe with milk or sand but they wasn't...Have no pics of them :( But after change for new ones i'v done about 1000 miles and i check color of new ones and color was like it should-"coffe with milk" :)
I newer run my bike in a rain so i can't change ECM from another bike to check ECM is it faulty but i hope even with different ECM light from FI will still be on. It will mean something less important will b broken or faulty :)
By revs i mean range around 7-9000rpm
Any sugestions MADBUYER?
BTW never had any probs with temperature in my bike.Tomorow will try switch off PC3 and will put new ECM unit and we will see is this gonna make any difference :(
 

·
Registered
Joined
·
8,655 Posts
If you unhook the PC AND install a different ECU, how will you know which one is affecting change-if any? Better try one thing at a time.
 

·
Premium Member
Joined
·
8,328 Posts
If you unhook the PC AND install a different ECU, how will you know which one is affecting change-if any? Better try one thing at a time.
^+1 one connection at a time...
 

·
Registered
Joined
·
39 Posts
Discussion Starter #11
I just check computer in my bike.I put computer from another SP1 and still light FI is on above 7000rpm on 6th gear.Tomorow i will try disconnect PC3.
I'm thinking about high voltage cable from spark plugs.Maybe they r not connected properly...Need to try any option!!
 

·
Registered
Joined
·
39 Posts
Discussion Starter #12
WIthout power commander is the same:(
I'v clean high voltage cables by proper spray ,spark plugs r OK, and still no results
I start wondering is it not petrol?
Its only on 4,5,6th gear and 7000rpm or more
 

·
Registered
Joined
·
39 Posts
Discussion Starter #13
Guys,problem was in sh...t petrol!!Yestarday i change petrol and straight away bike was more powerfull,no light FI and 183mph again!!!Shell petrol station in scotland r sh..t!!
 

·
Premium Member
Joined
·
8,328 Posts
I use a syringe test on my local gas stations from time to time.

Take a sample out of your tank or my favorite, grass cutting can. Let the sample sit for a few days and the water rises to the top.

Just the nature of things there will always be some water in gas but if it is over 5mm in the syringe, I call the station manager to treat their tanks as this is a rip off if its done intentionally.

This is why I use the BP or Shell gas stations that are busy and turn their gasoline supply over quickly.(Marathon is a close third too in this area)

Glad you found it was just bad gasoline.

Next time I test I will post up so you can see exactly what I am talking about.:cool:
 

·
Registered
Joined
·
8,655 Posts
I use a syringe test on my local gas stations from time to time.

Take a sample out of your tank or my favorite, grass cutting can. Let the sample sit for a few days and the water rises to the top.

Just the nature of things there will always be some water in gas but if it is over 5mm in the syringe, I call the station manager to treat their tanks as this is a rip off if its done intentionally.

This is why I use the BP or Shell gas stations that are busy and turn their gasoline supply over quickly.(Marathon is a close third too in this area)

Glad you found it was just bad gasoline.

Next time I test I will post up so you can see exactly what I am talking about.:cool:
Who brought the brainiac? :D
That's a great idea Mb!
My local news had a trailer about a story claiming that we all get ripped off by the gas stations in the heat of the summer because the metering isn't accurate at the gas pump when it's 90+ degrees F.? Do you know what that is? (I didn't get to see the story...)
Oh yeah, water is heavier than gas, so if it's floating on top of the gas, I don't see how it could be water. :confused:

Guys,problem was in sh...t petrol!!Yestarday i change petrol and straight away bike was more powerfull,no light FI and 183mph again!!!Shell petrol station in scotland r sh..t!!
I didn't realize you were from Scotland. I have relatives in Aberdeen. Both my fathers parents immigrated from Scotland. Sure hope I can make it there someday!

And most of all, I'm glad your problem was such an easy fix!
 

·
Registered
Joined
·
39 Posts
Discussion Starter #17
I didn't realize you were from Scotland. I have relatives in Aberdeen. Both my fathers parents immigrated from Scotland. Sure hope I can make it there someday!

Well...I'm polish but i stay in Edinburgh :p
 
1 - 17 of 17 Posts
Top