RC51 Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
I have a 2001 RC and one day I came out to start the bike , I did not hear the fuel pump prime . I pushed the starter switch back and forth and it primed ! It started to where i needed ro push the switch 15 to 20 times to hear it finally prime ! I purchased a new oem switch and it does the same thing . Any suggestions guys ?
 

·
Registered
Joined
·
8,655 Posts
Fuel pump relay and bank angle relay would be my first suspects.
Bank angle sensor and kickstand switch could also give you the same problem.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
I did check the fuel cutoff relay, and the bank angle sensor relay, both have good continuity going to them, and they both click when you turn on the ignition !
 

·
Registered
Joined
·
98 Posts
my fuel pump prime problem turned out to be a crappy connection through the pump. Theres a brass rivet underneath that green exoxy stuff. I had to re tighten the connection and re epoxy it. Not fun. Nor did I have confidence its not going to loosen up again and leave me stranded somewhere.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #6
As a precaution, I did order a new fuel pump, fuel filter, and in new oem starter switch ! However I've been told if the fuel pump primes then that's not a bad fuel pump !
 

·
Registered
Joined
·
8,655 Posts
The fuel pump is one of the last things on my list. So many other things that are tied to it that need to be checked first.
Did you try swapping the Highbeam relay. Put the fuel cut relay into the highbeam relay and cycle the highbeam a few times. Same works with the bank angle relay.
Pilot has a good point about connectors. There's a connector on the left side near the gas tank hinge that should be checked too. As I recall, it's a 3P connector.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
I got home last night and lifted the tank

I checked the fuses on the left side of the bike- there -Good

I checked the bank angle relay and the fuel cut relay there - Good

I checked the high beam on my bike it's -Good

I checked for any loose connections under the tank and by the fuel pump and also for any pinched wires were the tank pivots there - Good

When I lifted the tank there was very little gas in it , would that make the fuel pump not prime ?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #9
I did check the 3 pin connector on the left side of the bike , I pulled it apart and applied dielectric grease . Any other suggestions guys ?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #10
So I'm out in the garage tonight with my girlfriend looking over the bike and she says why don't you for giggles switch the headlight relay and the bank angle relay! You can really feel the fuel cut off relay when the Fuel Pump comes on intermittently and very little with the bank angle relay ! So I did that and now you can feel both really click and the fuel pump primes like a mofo! I tried it for 45 min intermittently on and off and it primed everytime ! I HOPE THIS WAS MY ISSUE I'm ordering two more relays just in case and I'll put a picture up on Amazon if anybody else wants to order them also
 

·
Registered
Joined
·
2,181 Posts
I wonder based on the feedback so far if everything has been evaluated thoroughly. If so, there are multiple threads here that also note intermittent shorts with the fuel pump wiring underneath the tank.... in various spots. That should be evaluated, tested and diagnosed; it does require more than a quick look.

Hope this helps.
 

·
Premium Member
Joined
·
3,237 Posts
For an easy start

Get a 12V - 1 or 2Watts bulb, solder two wires on it, one + and one ground and mount it on your triple or somewhere easily visible.
Attach the ground wire somewhere on the frame under a naked bolt for example.
The other wire, the + one, attach it on the Brown cable on the pump's connector.

Check that when you hear the pump priming, the bulb comes on.

Then start using your bike like you used to until you don't hear the pump priming.

At that point, if the bulb is on but the pump doesn't prime, the issue is on the pump.
If the bulb doesn't come on every time the pump fails to prime, then your pump is ok (for this first step at least)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #17
I did the jumper wires to the fuel pump and the fuel pump primes strong ! Should my starter relay make a clicking noise at all when I go to start the bike ?
 

·
Premium Member
Joined
·
3,237 Posts
Does the light comes on each time you hear the pump primes?

The starter relay should not make a repeated clicking noise when you push the button.
It only click once when it arms the starter but you can barely hear it cause of the engine cranking
 
1 - 20 of 21 Posts
Top