RC51 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I fitted the Factory Pro shift star and spring to try and prevent the missed shift 3-4 and 5-6 which happens while using a quick shifter. I backed off the cut timing to 90ms and it does shift better now but I still have a miss on most 3-4 shifts while hot. I also notice the gear lever sometimes binds up.

While I had the bike apart I noticed the shift spindle was worn on one edge (see left side of picture). The gear lever sometimes binds up so this is possibly the cause. The part # SPINDLE, GEARSHIFT 4610-MCF-000 . I'm planning on replacing all of the cooling system hoses and clamps and will add a new Spindle to the order.

Has anyone had a similar problem with a worn shift spindle causing the shifter to bind and have missed shifts?
 

Attachments

·
Premium Member
Joined
·
3,189 Posts
Not with the RC. My Fireblade had some similar issues, but was due to some work shift forks. I replaced the shift forks, shift drum, rod, linkage and installed the factory pro kit and it shifts like new.
 

·
Registered
Joined
·
51 Posts
I have had issues on the track bike mainly in the range you are dealing with(3-4, 5-6). Ive always chalked it up to rider error, and at times bikes are mechanical after all so I can accept an error here or there. Last year it became a little more of a regular occurrence. I just upgraded to a PC5, and installed a QS, in hopes it helps. Also I know how oil can play a big part in things too, some bikes are just temperamental, and am switching over to amsoil. All this aside, my point is I hope I am not plugging holes in the dike with my finger. Keep us posted on what you find Ripahh, thanks!
 
1 - 4 of 4 Posts
Top