RC51 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Every now and then my bike will be hard to start. The bike will kind of rest the trip meter when trying to start. Not sure what wrong with it but only happens some times.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #5
Battery is brand new put it in when i got the bike maybe a few weeks old now. Battery connection is solid not sure about other connections but the positive and negative connection to the battery is good.
 

·
Super Moderator
Joined
·
6,481 Posts
Usually I see the symptom you describe either due to a low battery (for various reasons) or cold weather.
A few years ago I tried to start the engine when the temperature had dropped to freezing.
The battery was charged (via battery tender) and everything was in proper working order, it was the fact the battery couldn't provide the starting current at that temperature with 10W40 oil. It would turn over, just not fast enough to catch.
The next day, when the temperature rose to 42 deg, it started with no problem.

Since you have a new battery, and have good clean and snug connections at the battery posts, I'd check if your system is properly charging the battery.

Crank your bike up and place a voltmeter across the battery posts, then rev the engine to 4000 RPM.
You should be getting 13.5 to 14.5V on average.
If you're getting less than 13V, I'd check your stator coil resistance, and coil to ground resistance.

If the stator coils check out, it could be corroded contacts at the rectifier/regulator connector or possibly the rectifier/regulator itself.

Refer to the service manual for all the checks.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #7
Thanks for all the help guys. I got a service manual so when i get time i will test everything. I'm pretty sure i need to replace the rectifier or stator or both. :(
 
1 - 7 of 7 Posts
Top