RC51 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
so I ran into another problem arghhh. Only one side of my headlights work. I have aftermarket lights fyi. fuses are good or the only fuse for it is. I checked with a volt meter thing and I'm not getting any power. what do I check next? I'm lost
 

·
Registered
Joined
·
355 Posts
Of course check your plugged connections, is your switch bad? Open it up and look for corrosion or obvious damage.

With the wiring problems you've had with that bike sounds like you may just have a F'd up harness man. If you're not concerned with high/lo beam you just want both on at the same time I guess you could just run a jumper wire over from the side that is getting power to the side that's not but that a half assed job lol.

If it were mine, and you haven't fixed the blinker issue you were having I'd go ahead and pull the harness out and have a good look over it for cuts slices and hacks and either repair or replace it. I had a brake light issue I just coulnd't find were the problem was I spent hours and hours trying to find it. Spent 40 bucks on a uncut Ebay harness and Viola fixed! Wish I could be more help I'm not that great with electrical stuff.

0.02
 

·
Registered
Joined
·
71 Posts
Discussion Starter #5
blinker problem has been fixed :). it was just missing a relay. got one from cycle gear and plugged it in and boom. I don't think its the switch as the second headlight outlet doesn't have power. I checked using a volt meter. I would like a high beam and also just in case its needed for inspection when I get this bike inspected
 

·
Registered
Joined
·
355 Posts
Cool, if the switch isn't functioning it wouldn't put power to the hi beam...

The RC's only use one light on lo beam.
 

·
Registered
Joined
·
8,655 Posts
you may also be missing the high beam relay. given you were missing the signal relay
That's the first thing that popped into my mind too: the high beam relay.

Sanee, the high beam relay should be located tucked inside the front and inner panels near the top and the turn signal. So just under your left clip-on. There should be a socket that you plug the relay into, and it's the same type of relay that the fuel-pump, bank angle uses, (and on SP2, the fan control). So you can swap in one of these (known good) relays to see if that will power your high-beam.
Hopefully that relay socket wasn't cut out of your harness...
 

·
Registered
Joined
·
71 Posts
Discussion Starter #9
That's the first thing that popped into my mind too: the high beam relay.

Sanee, the high beam relay should be located tucked inside the front and inner panels near the top and the turn signal. So just under your left clip-on. There should be a socket that you plug the relay into, and it's the same type of relay that the fuel-pump, bank angle uses, (and on SP2, the fan control). So you can swap in one of these (known good) relays to see if that will power your high-beam.
Hopefully that relay socket wasn't cut out of your harness...
hah damn. just went to take a look and any chance is it a 4 prong socket? theres an empty slot like you mentioned under the left clip on together where I would plug in the headlights. if so can I get this relay from cycle gear also or wheres the best place?
 

·
Registered
Joined
·
8,655 Posts
Yes, that has to be it.
I couldn't find relays anywhere besides a Honda dealer. They're about $45 each as I recall. I would recommend buying at least one extra if budget allows since the same type is used in 4 places on the bike. Nice to have a spare as they do fail on occasion. My fuel pump relay and bank angle relay gave up within a couple weeks of each other.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #11
Yes, that has to be it.
I couldn't find relays anywhere besides a Honda dealer. They're about $45 each as I recall. I would recommend buying at least one extra if budget allows since the same type is used in 4 places on the bike. Nice to have a spare as they do fail on occasion. My fuel pump relay and bank angle relay gave up within a couple weeks of each other.
I've been emailing this guy at cycle terminal regarding all my wiring needs and he's been great. just noticed he has relays also and just asked him if he has what I need. hopefully thats whats needed and I'm done. thanks again for chiming in. ill post up when I get finally get it here and installed.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #12
so I figured since you guys said the bike uses like 4 of the same relays, I took one of em out and plugged it in the headlight relay spot. Boom!!! I have both lights now and high beam works. I am finally done with all the guess work. I just need to figure out where I want to mount my lights. there was a person selling relays on eBay for $10 but I figured since these things go bad eventually I ordered one online. $37 shipped for peace of mind on a new part. can't wait for more parts connectors and so on to arrive prob next week and get all of this together. then get the bike inspected to be road worthy yay. thanks again to all of you who helped me with my million of questions
 
1 - 15 of 15 Posts
Top