RC51 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I just bought my first RC51 a couple of days ago, which, I feel it was a deal I could not pass up. It is an 02 with only 480 miles (yes 480 miles). Better yet, I paid $5800 for it and the original owner threw in a new Shoei helmet, jacket, and gloves. The only problem I have with the bike is since it has been sitting for so long, the bike will stall out when I come up to a red light. Embarrassing when spectators are observing the brand new condition of the bike. Although, I have bought new plugs and am waiting till I completely run the bike out of the junk gas to install them, hoping that it will resolve the problem. I would appreciate it if any experts can give me some advise as to what this problem may be.
 

·
Premium Member
Joined
·
6,481 Posts
You'll have to provide as much information as possible to help with the diagnosis.
You say the bike only stalls when you come to a stop.
Does that mean the bike runs fine other than this?
What is your idle speed? It should be 1300 +/- 100 RPM. It may be too low.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
The bike seems to run and idle fine when it is cold, but, after it seems to warm up it will start to sputter and will eventually stall when it comes to a complete stop or even when I slow down to approach a red light. I just changed the plugs which shown that the bike was running extremely rich. The rear plug was actually still wet. Hoping it was just the effects of bad gas, but I will soon see and update any additional information. The idle was at 1300 before and after the plugs were changed so it can't be that. I am hoping that it is just as simple as changing the plugs.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4 (Edited)
After I changed the plugs the bike seems to run much better but still acts like it is running too rich. Is there a way I can adjust this problem? The reason I believe it is running rich is due to the strong exhaust smell when at idle and at take off. Also, my idle jumped up to 1500 rpm after the bike gets warmed up. Any suggestions are appreciated.
 
1 - 4 of 4 Posts
Top