RC51 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I was riding the other day and the bike missed, just like I hit the kill switch for a sec and fired back up. Yesterday I was riding and I started doing it again only more frequently. I was thinking either theres a short in the kill switch, or the kickstand switch? Bc the bike is behaving just like I turned it off...ie no tach, fi light comes on...etc
 

·
Registered
Joined
·
13 Posts
Have you had the tank up lately? If so check your fuel line routing.

Check your battery connections, could be loose.
 

·
Registered
Joined
·
159 Posts
Have you had the tank up lately? If so check your fuel line routing.

Check your battery connections, could be loose.
All of these are great suggestions but I will say my bike did this same thing and it turned out to be the wires going to the fuel pump under the tank. They get pinched between the tank and the frame. Not that there is any greater chance of this but I thought I'd through it out there.
 

·
Registered
Joined
·
1 Posts
i had this problemon my 04 do u have a undertail kit installed. if so please check the relays in the trunk compartment. one of the relays is loosing power momentarily and coming back on. so check into this.
 

·
Registered
Joined
·
145 Posts
I had a similar electrical on/off problem with an other bike, 4cyl, and it happened 2-3 times while on a turn. Thankfully I wasn;t going all out, just urban mellow riding, but kept thinking that a similar thing on the RC would have sent me on my face before I realized what happened. If you don't believe me while on a curve and under some throttle hit the kill switch if you dare!
 
1 - 13 of 13 Posts
Top