RC51 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
My low beam headlight stopped working which apparently was a HID bulb, got the bike a few months ago and hadn't noticed since I ride only during daytime. I did notice it was a hint of blue but figured it was one of those ricer bulbs.

My question being are these kits fairly easy to bring back to stock? I do not want the HID. I noticed that the standard H7? adapter is gone in place of the HID bulb. What would be needed to bring back to stock. Thanks in advance.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
Update - I have since ordered the OEM socket adapter and rubber cover since the original one was hacked a bit.

I guess I need to order a connector, similar what the OEM used. The connector looks kind of like a H4 adapter even though the bulb is a H7, little confused.
 

·
Registered
Joined
·
203 Posts
When I changed mine after looking at it a few times I noticed the socket is already connected to the ballest but 'inverted'(?). Pulled that apart, connected a new bulb and was good to go. Thought I needed all those new bits as well but were already there.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
When I changed mine after looking at it a few times I noticed the socket is already connected to the ballest but 'inverted'(?). Pulled that apart, connected a new bulb and was good to go. Thought I needed all those new bits as well but were already there.
Just an update. I removed the whole HID system, it had lowbeam power going into the HID ballast. Once that was removed I bought a H4 adapter with pigtais off eBay and bought the OEM Honda bulb adapter which fits the standard H7 bulb. Works fine now. :)
 
1 - 5 of 5 Posts
Top