RC51 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi All!

New member here with a technical question. I have a 2000 RC51 , picked it up fairly cheap , been working on her since Feb 2010. Finally got her together and on the road for test runs only. I was having problems with water squirting out of Rad cap, fixed that and now after I run her hard she starts to miss. The F1 light comes on and blinks eight (8) times. Does any of you fellow RC riders or knowledgeable riders know how to interpret the F1 codes? New coolant hoses , new thermostat , new Rad cap , cooling fan works and temp is normal. Yet she seems to mis after I run her. Let her sit for an hour or all night and she runs fine, till I run her hard again. Thanks for putting up with an RC green horn.
 

·
Premium Member
Joined
·
6,479 Posts
8 blinks is a throttle position sensor (TPS) problem, or related wiring problem.
I'd check the TPS connector first.
If the TPS is indeed bad, you'll have to replace the whole throttle body assembly.
The TPS can't be replaced as a component.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Hey subsailor,

Thanks for the response. You are on track, found a service manual and performed all the checks they asked, only to find it passed all test and ultimately pointed to the ECU, Drats. Is never easy is it. Thank you again........spacerider out
 

·
Premium Member
Joined
·
8,328 Posts
Hey subsailor,

Thanks for the response. You are on track, found a service manual and performed all the checks they asked, only to find it passed all test and ultimately pointed to the ECU, Drats. Is never easy is it. Thank you again........spacerider out
Good used ECUs are on EBay all of the time...
 
1 - 4 of 4 Posts
Top