RC51 Forums banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
365 Posts
Discussion Starter #1
First off, most expensive battery I've ever bought!! Second, I put the new battery in and I have no power whatsoever to the bike. Yes, terminals are hooked up correctly. I've tested the battery, putting out 13.2V, the main fuse is good tested with DMM. It ran fine yesterday but was a little hard to start so I thought it was a battery problem but now I'm not sure what the problem could be. There has to be something that isn't right to cause the bike to have NO POWER at all, just not sure. All info is appreciated.

James
 

·
Premium Member
Joined
·
365 Posts
Discussion Starter #4
well, no power means..........no power at all...........nothing comes on at all. I was reading that it could be a main fuse in the fairing but I'm not to familiar with the RC51 quite yet but hoping to get some insight here, thanks again guys
 

·
Registered
Joined
·
19 Posts
Please pardon my ignorance on this as I have not even taken delivery of mine yet. That being said....I have read what feels like every page in this site. What I have learned is that the wires sometimes tend to vibrate and rub causing them to short. The extra voltage might cause the short to have happened all the sudden if the battery you just replaced was not as strong. (another reason for a hard start) Also, I have read that there is a fuse that looks like your signal relay that could have gone out. Again, I realize this is vague, but I am trying to give you what little bit I know.
 

·
Registered
Joined
·
10 Posts
I think the first thing i would check is the battery still grounded(and i dont mean on the battery terminals) ? After that i think it is time to start chasing wire and checking voltages. Do you have a service manual for the bike? If not PM and we can see about getting my electronic copy to you.
 

·
Premium Member
Joined
·
365 Posts
Discussion Starter #7
I don't have a manual for the bike, I checked all the small fuses on the side inside the fairing and they were still good. I have to check about the battery being grounded or not. I guess I'm going to have to get wiring diagram and grab my DMM and go at it. thanks for all the help guys!
 

·
Registered
Joined
·
19 Posts
I don't have a manual for the bike, I checked all the small fuses on the side inside the fairing and they were still good. I have to check about the battery being grounded or not. I guess I'm going to have to get wiring diagram and grab my DMM and go at it. thanks for all the help guys!
What part of town are you in. I will come and help if you are close. Within an hour plus or so!:D
 

·
Premium Member
Joined
·
365 Posts
Discussion Starter #9
Virginia Beach, aren't you in TX??
 

·
Premium Member
Joined
·
365 Posts
Discussion Starter #11
It was that 30amp fuse right behind the rear plastics, man am I glad to hear that baby roar again
 
1 - 11 of 11 Posts
Top