RC51 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys new here! If the bank angle sensor is bad would I still have power to the fuel cut of relay? I have no constant power to it!! Unplugged power commander still nothing. This all started when I’d ride the bike then stop leave the bike in the sun... I live in vegas it’s been HOT.... go to get on it and the fuel pump would just thump but not prime I’d let it sit in the shade cool down and boom!! It would prime again. So I took the plastics off unplugged relays make sure there clean checked wiring and now nothing power commander wasn’t turning on so I took it out and plugged stock back together and still nothing. It will turn over but pump won’t prime and I have no power to fuel cut off relay or anything important! Have power to lights🤷🏼‍♂️
 

·
Registered
Joined
·
1,715 Posts
the power wire on the fuel pump relay is the black/white

it is fed from the BAS relay where it goes from red/white to black/white

check that you have power on the red/white

that wire should be constantly powered and comes from the tape wire at the battery positive.

it could be a loose connection somewhere in there. perhaps at the fuseholder or maybe the single pin inline connector.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I have power at the red and white no lose connection at the fuse and no constant power to the fuel cut off relay
 

·
Registered
Joined
·
1,715 Posts
when the key is on and kill switch set to run, do you have power at the black/white?

if no, check the "ignition" fuse in the fuse box.

this powers the kill switch which in turn supplies the BAS relay.

if this fuse is good, you can unplug the BAS and short the red wire to the green wire in the connector and try again.
 

·
Registered
Joined
·
1,715 Posts
Do you have 12v on the solid black wire? The smaller gauge black on the bas relay, this comes from the kill switch

If you have 12v there then replace the bas relay with the high beam relay and try again

If you don't have 12v here, bypass the kill switch by jumping from white/black to black in the 9 pin red connector.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Ahhhhh just exposed all the wires in the tail then put the relay from up front onto the BAS and boom it fires🤷🏼‍♂️I did that yesterday and nothing so I’m gonna get all new relays and just keep checking wires and connections and tighten them up!!!! Thank you for yr help!!!!!!!!!!!
 
1 - 8 of 8 Posts
Top