RC51 Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
so my 03 has recently started running hot. even on highways it hovers in the 230s. and in town its 240s, never gets any hotter but just stays around there. ive flushed the coolant, running water wetter. the fans kick on at 220. im pretty sure the thermostat is working, but i have a new one on order just in case. and the hose coming outta the water pump does have drips coming out of it. the sign of a bad mechanical seal, right? so that is on order too. will those two parts be the culprit? anything else i should look for? besides the usual leaky hoses and whatnot. ive been reading all i can to find a solution. just seeing if theres any advice that ive missed. thanks for any help
 

·
Registered
Joined
·
753 Posts
Never used water wetter before but I do use Engine Ice http://www.engineice.com and swear by it. Oddly enough we were just discussing this earlier.

http://www.rc51forums.com/forums/showthread.php?t=48874&highlight=engine+temp

One thing I might suggest is to see if there is any sludge in the pipes or rads, if someone previously tried to fix that leak with 'stop leak' then Im afraid its gonna be a pain in the arse getting those rads cleaned out. Hopefully they didn't as this would not help in cooling the engine as it'll reduce the flow through the rads.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
yep, i just read through that thread too. are spal fans worth looking into?everything ive read, everyone swears by them. it never gets miserably hot here, or im never in traffic jams or anything like that so i didnt think it was completely necessary
 

·
Registered
Joined
·
666 Posts
Fans

In SOCAL, temps can rise to over 110..I cahanged mine to spal pushers...helps a good bit...I believe there is a thermostat from another bike that will kick the fans on at 180 or so.....
 

·
Registered
Joined
·
63 Posts
I've gone with the Turn One radiator shrouds, Spal pusher fans, Samco silicone rubber hoses and Evans waterless coolant. In 90+F weather it will get to about 220F but when the fans kick on, the temp drops like it should. I tried Engine Ice and it worked no better than the OEM anti-freeze.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
so i guess i should try the pusher fans if these other two parts arent the solution. just seems like hovering around 240 is very hot. like something is wrong other than being a very hot blooded machine.
 

·
Premium Member
Joined
·
2,697 Posts
I have most of the cooling upgrades for the side mounts, engine ice, twin spal and the fins. So minus the internal scoops.

90 degree F plus ambient temperature and my bike never sees anything above 190 while cruising on the hwy.

Make sure that your coolant system is clean, clean it like a coffee maker. Make sure the thermostat is working right, and use engine ice. Even with stock fans the bike should stay cool, under 220.

Sent from Motorcycle.com App
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
new thermostat is installed. i just put the old coolant back in to see if it worked. it seemed to help, i didnt get to test drive it. but the temps still climbed to 240 before i shut it off. ill flush the system real good this weekend and get some engine ice. hopefully thatll take care of it. waterpump will have to be another day. plus that seems like quite the project anyway
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
i tore the bike apart again to find out the impeller had basically came disconnected from the shaft. the sure sign of my bike running hot. parts are on order right now.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #13
i was very surprised. i thought it would be on splines or just one full piece or something. but no, it was just sitting there and spinning freely. not attached at all
 

·
Registered
Joined
·
134 Posts
At a 100* trackday @buttonwillow fast a group pace the bike will get in to the 230's. I back off a little to bring it down at that point. I have a spal pusher waiting to be in stalled. As well as plans for a subframe undersheet to organize and hold all electronics minus the battery. Want to relocate with a DHC relocate kit.
 

·
Premium Member
Joined
·
1,536 Posts
Currently at the track, 95 outside, bike is staying between 230-233...cools down to 215-220 when I pull into the paddock.

Running water and water-wetter.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #16
i finally got it all put back together. flushed the radiators with distilled water, added engine ice. runs perfect. gets up to 220 and the fans kick on and goes back down right away. so glad i got this taken care of
 

·
Registered
Joined
·
37 Posts
I have done something different on my SP2:


First, I replaced both fans with SPALs and they've done their job very nice, BUT the kick in at 219° and stop at 212° so a steady on-off-on-off in the city.


Also i noticed, that the SP drops temps very slow, even when driving fast. I think that was caused by the SPALs which cover a lot of the rads and lower the function of them when not spinnibng.


So I removed the left SPAL and mounted a foam shield in that way, the rad got a bit more air. Works fine.

However, I would suggest to install a manual switch for the fan or an adjustable thermo switch.




 
1 - 17 of 17 Posts
Top