RC51 Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter · #1 ·
Hey guys,
I was riding to work this morning and ata red light I noticed a little smoke comming from the left radiator.. As I waited a thhe red light my temp climbed up just past 200 until I decided that was enough and just ran the light. I never heard the fan click on.. Could this be the problem? Otherwise the bikes running fine. Thanks for any help..
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #3 ·
217.. I thin thats right around the temp I left the light at.. I didnt hear it click on. When I parked it I was trying to listen for anything or feel anything.. It was still dark out.. I thought I felt some moisture above the radiator but since it was early morning its hard to tell if it was coolant leaking from smewhere or just condensation.
 

·
Registered
Joined
·
863 Posts
What you need to do is park it and let it idle till it gets up to operating temp and then start looking for leaks, you should be able to see them pretty quick. Mine was a pin hole leak right near the top. Also let it idle till it gets real warm and see if your fan is coming on if it doesn't just make sure to turn it off before it overheats :D
 

·
Premium Member
Joined
·
6,495 Posts
For whatever reason, leaks from the left radiator are more common than the right radiator.
Also, check if the bearings in the fans are ok.
When I was checking my coolant leak issues, I noticed my left fan bearings were squeaking when spun. So I replaced both fans to be sure.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #8 ·
Thanks for the info... I never got close to 251 so that makes me feel better.. Looks like rain tommorow so Ill look at it after work then..I appreciate you guys helping me out.. Thanks again!!
 

·
Premium Member
Joined
·
6,495 Posts
217.. I thin thats right around the temp I left the light at.. I didnt hear it click on. When I parked it I was trying to listen for anything or feel anything.. It was still dark out.. I thought I felt some moisture above the radiator but since it was early morning its hard to tell if it was coolant leaking from smewhere or just condensation.
Yeah the fans don't come on until around 217-218 and stop at around 205 I believe. Well, at least mine do.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #10 ·
well I had to run an errand after work and when I got there I stopped for a min and could see a good amount of coolant coming out from behind the left side lower, the temp never even got to 200 though. I got home and it looks like ill need to pull off the fairing and run her to see where its coming from. Ill do it on Wed when im off..
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #13 ·
oh its not small.. by the time i got home my lest side can had antifeeze all over it.. im hoping one of the clamps came loose..
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #14 ·
well bad news..the left side radiator is bad.. I pulled off the fairing and cleaned up the old mess and started her up and watched coolant build up inside the radiator. to make matters worse I called a local salvage place and the guy said he had one but to bring my old one down to be sure.. I bring it down and they match up so I buy it.. I get home and take off the fan low and behold its not the same radiator.. the tabs to mount the fan on this one point in and the one on mine point out. so now i get to go back tomorrow and get my money back..
 

·
Premium Member
Joined
·
6,495 Posts
He may have compared it to a radiator from an VTR1000F (Super Hawk).
It also used side mounted radiators that looked a lot like RC51 rads.

My left radiator had a puncture in the upper tank area. Definitely not a pin-hole leak.
The previous owner JB welded it, but the glue broke loose.
So I took it to a shop that did aluminum radiators.
They cut out the bad section and welded up the hole, then welded the tank back together and pressure tested it.
It's been working super ever since.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #16 ·
thats exactly what i thought.. Im going to go ahead and mount it in the morning and ride it for a few days and see how the temps are.. Im not sitting in traffic hardly at all so it shouldnt be a problem..
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #17 ·
ok the superhawk radiator is mounted and I left the fan off.. I cleaned all the spilled/leaked coolant out from inside the fairing and buttoned that side back up. Started her up let her warm up and took a ten minute ride.. everything seems ok.. I never got on the freeway so the temp hung around 230.. The PO told me he had the radiator repaired and its under warranty so Ill take it back and get it repaired again and put it back on when I get around to it.. At least I can ride in the meantime..
 

·
Premium Member
Joined
·
6,495 Posts
ok the superhawk radiator is mounted and I left the fan off.. I cleaned all the spilled/leaked coolant out from inside the fairing and buttoned that side back up. Started her up let her warm up and took a ten minute ride.. everything seems ok.. I never got on the freeway so the temp hung around 230.. The PO told me he had the radiator repaired and its under warranty so Ill take it back and get it repaired again and put it back on when I get around to it.. At least I can ride in the meantime..
Man I hope San Diego's freeways aren't as congested as L.A.'s, or your temp with rise above 230 if stuck in gridlock.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #19 ·
no worries..I barely commute.. I work about 8 miles from home. straight shot 1 freeway it takes me about 10 min tops.. now if i had to go si ton the 5 up in north county that would be a different story
 
1 - 19 of 19 Posts
Top