RC51 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have an 03 Rc, Has 25,000 miles on it. Yoshi shorty slip ons and different gearing. Bike will start up fine un run great, then no matter what speed or gear bike will cut off. All lights will stay on and the FI light comes on (just like if you hit the kill switch) While still rolling the bike will sometimes kick itself over and others I have to come to a complete stop. Ill let it sit for a few seconds hit the starter and bike will fire back up. Any ideas of what to check?
 

·
Premium Member
Joined
·
365 Posts
Well, I have an '03 and I had a similar problem (@ about 29k miles) with mine and it actually was the kill switch. I'd accidentally touch/tap it with my hand while riding and it would cut off then come back on. I bought a OEM one form bikebandit and that was def the problem............just a thought
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
I'll have to look into that. I know my hand was nowhere near the kill switch when it happened. So far ive checked the pulsor coils, battery terminals, tip over sensor, and havent been able to come up with anything
 

·
Premium Member
Joined
·
365 Posts
It only cost me 37 bucks and all in all if it wouldn't have worked, i'd had a new one now but it did so.
 

·
Registered
Joined
·
159 Posts
Look at the kickstand spring and make sure it's keeping the kick stand tight in the up position. Even if it is, they do sometimes get road grime in them and go bad.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
I had one of the techs at work test ever system and run diagnostics on everythink, couldn't find anything out of sorts. Now bike runs fine and the light hasn't come on nor has the bike shut off, weirdest thing
 

·
Premium Member
Joined
·
8,335 Posts
I once had a short inside the kill switch assy. The solder joint had pulled off the small circuit board....started as an intermittent issue then finally all of the solder melted away leaving a charred wire.
 

·
Registered
Joined
·
1 Posts
i had an '00 that I sold because of the intermittent ignition cutout.. It would ofter die for a second while accelerating from 3000-4000 rpm - the F1 light would come on but never blink on the next startup like it says in the service manual. Or, it would die for a second or stutter for a few cutouts while just cruising at highway speed. No way I did it with the on/off switch. Bad lean angle sensor? Cycle World Service page has mentioned some other Honda models have had oversensitive lean angle sensors.
So I now have an 04 Nicky Rc51. It was great for the first year and then it started doing the EXACT SAME THING!!!!!!!! only worse - once it died for 3-4 seconds at highway speed - not very reassuring. Seeing that other owners have the same problem is very worrisome. Is this particular to RC51's in general.
I have lost all confidence in this bike
 

·
Premium Member
Joined
·
8,335 Posts
Are you kidding...lost confidence???? This bike is a beautiful masterpiece. If you lost confidence then you have no soul... I have had ZERO the issues you describe with two RC51's owned... The first is 2003 with 21,000 miles and the recent purchase of another 2003 with 4,700 miles...
 
1 - 10 of 10 Posts
Top