RC51 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
I had my RC in traffic for the first time the other day, and sure enough a few lights in a row and saw temps heading to 240 before I got moving and cooled it down.

I have started to dig into it (BTW this is a recent purchase which I got fairly inexpensively, knowing there would be a bunch of niggly crap to deal with), anyway this is what I found. :serious:

1) 2P connector is a drift and therefore not grounding??
2)Wire to thermo switch is in the breeze also...

I had already jumped in and have a bracket from Wibbly on the way, thanks mate! And a Spal on the way off of Amazon

I guess I am looking for confirmation that the connector grounds via the tab which should be attached to the rad...
 

Attachments

·
Registered
Joined
·
1,628 Posts
the ground is supplied by the thermal switch on the radiator.


power goes into the fan, then off to the thermal switch.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
the ground is supplied by the thermal switch on the radiator.


power goes into the fan, then off to the thermal switch.
Copy that, also see a black wire connected to the back of the rad from the 2P connector. (the one the zip tie is pointing to)

I have some cleaning up to do in there with the weirdo indicators that are hooked up.

Rear harness is freak'n mess too, so many dodgy connectors.

What gauge wire should I be using when I am cleaning things up?

And should I go with a regular connector that I can shrink wrap?
 

Attachments

·
Registered
Joined
·
86 Posts
Discussion Starter #4
By shrink wrap I mean heat shrink...
 

·
Registered
Joined
·
86 Posts
Discussion Starter #7
Awesome, thanks guys!
 
1 - 7 of 7 Posts
Top